HDU 5762 Teacher Bo (暴力)

21 篇文章 0 订阅

Teacher Bo

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 24    Accepted Submission(s): 12


Problem Description
Teacher BoBo is a geography teacher in the school.One day in his class,he marked N points in the map,the i -th point is at (Xi,Yi) .He wonders,whether there is a tetrad (A,B,C,D)(A<B,C<D,ACorBD) such that the manhattan distance between A and B is equal to the manhattan distance between C and D.

If there exists such tetrad,print "YES",else print "NO".
 

Input
First line, an integer T . There are T test cases. (T50)

In each test case,the first line contains two intergers, N, M, means the number of points and the range of the coordinates. (N,M105) .

Next N lines, the i -th line shows the coordinate of the i -th point. (Xi,Yi)(0Xi,YiM) .
 

Output
T lines, each line is "YES" or "NO".
 

Sample Input
  
  
2 3 10 1 1 2 2 3 3 4 10 8 8 2 3 3 3 4 4
 

Sample Output
  
  
YES NO

求是否有不一样的两个点之间的曼哈顿距离相同。


因为题目中限制了x,y的范围是M  那么曼哈顿距离最多只会有 2*M个  也就是200000

所以每组数据最多只会计算200000次


#include<cstdio>
#include<iostream>
#include<cstring>
#include<queue>
#include<cmath>
#include<map>
#include<algorithm>
#define ll unsigned long long
using namespace std;
struct node
{
    int x,y;
}e[100010];
bool vis[200020];
int n,m;

int Abs(int a)
{
    if(a<0) a=-a;
    return a;
}

void init()
{
    for(int i=0;i<=2*m;i++) vis[i]=false ;
    for(int i=0;i<n;i++)
    {
        for(int j=i+1;j<n;j++)
        {
            int len=Abs(e[i].x-e[j].x)+Abs(e[i].y-e[j].y);
            if(!vis[len])
            {
                vis[len]=true ;
            }
            else if(len!=0)
            {
                printf("YES\n");
                return ;
            }
        }
    }
    printf("NO\n");
    return ;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
        scanf("%d%d",&e[i].x,&e[i].y);
        init();
    }
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值