A == B?

Description

Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".
 

Input

each test case contains two numbers A and B. 
 

Output

for each case, if A is equal to B, you should print "YES", or print "NO".
 

Sample Input

    
    
1 2 2 2 3 3 4 3
 

Sample Output

    
    
NO YES YES NO

这个题主要是是比较两个数是否相等,唯一的陷阱是小数点后的0的个数会影响判断,这个代码的核心算法是看的一个大神的

代码;

#include <stdio.h>
#include <string.h>
void A(char *s)
{
    int len = strlen(s);
    char *p=s+len-1;
    if (strchr(s,'.'))//查找字符串s中首次出现字符c的位置
        while (*p=='0')
	    *p--=0;
        if(*p=='.')
	        *p=0;
}
int main(void)
{
    char *pa, *pb;
    char a[100024], b[100024];
    while (scanf("%s%s", &a, &b) != EOF)
    {
        pa=a;
		pb=b;
        while (*pa=='0') 
		    pa++;
        while (*pb=='0') 
		    pb++;
        A(pa); 
		A(pb);
        if(strcmp(pa, pb)==0) 
		printf("YES\n");
		else
		printf("NO\n");
    }
}



.

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值