#2054:A == B ?(水题坑人)

Problem Description

Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".

Input

each test case contains two numbers A and B.

Output

for each case, if A is equal to B, you should print "YES", or print "NO".

Sample Input

1 2
2 2
3 3
4 3

Sample Output

NO
YES
YES
NO

思路:

此题关键是找小数点,找到小数点把最后面无效的零去掉再比较就OK

教训:

一开始做的时候感觉好简单啊,直接string输入然后==比较,然后WA打脸了,发觉可能是大数比较问题,然后long double测试还是没过,想了很久才想到可能是精度问题如000123 和 123 还有小数点 ' . '的问题一些的,不断完善最后才AC了

AC代码

#include<bits/stdc++.h>
using namespace std;
void trim0(string& b)
{
	int len = b.length();
	if(b.find('.')!=string::npos)
	{
		for(int i=len-1;b[i]=='0';i--)
			len--;
		b=b.substr(0,len);
	}
	if(b[len-1]=='.')
		b=b.substr(0,len-1);
}
void main()
{
	string a,b;
	while(cin>>a>>b)
	{
		trim0(a);
		trim0(b);
		if(a==b)
			cout<<"YES"<<endl;
		else
			cout<<"NO"<<endl;
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值