bzoj 4098 [Usaco2015 Open]Palindromic Paths

Description

Farmer John's farm is in the shape of an N×N grid of fields (1≤N≤500), each labeled with a letter in the alphabet. For example:
ABCD
BXZX
CDXB
WCBA
Each day, Bessie the cow walks from the upper-left field to the lower-right field, each step taking her either one field to the right or one field downward. Bessie keeps track of the string that she generates during this process, built from the letters she walks across. She gets very disoriented, however, if this string is a palindrome (reading the same forward as backward), since she gets confused about which direction she had walked.
Please help Bessie determine the number of distinct routes she can take that correspond to palindromes. Different ways of obtaining the same palindrome count multiple times. Please print your answer modulo 1,000,000,007.
从n×n 的矩阵 左上角走到右下角会有一个长度 n+n+1的字符串,问有多少种走法使得路径字符串为回文?

Input

The first line of input contains N, and the remaining N lines contain the N rows of the grid of fields. Each row contains N characters that are in the range A..Z.

Output

Please output the number of distinct palindromic routes Bessie can take, modulo 1,000,000,007.

Sample Input

4
ABCD
BXZX
CDXB
WCBA

Sample Output

12
Bessie can make the following palindromes
1 x "ABCDCBA"
1 x "ABCWCBA"
6 x "ABXZXBA"
4 x "ABXDXBA"

noip传纸条的升级版

我们设它是从(1,1)和(n,n)分别出发的,f[i][j][k]表示走了i步,上面走到第j行,下面走到第k行(各自的列可以用表达式算出,有规律的)

但是我们发现n^3的空间开不下,于是改滚动

然后答案就是走了n步后每个f[0][i][i]的和

另外注意,f数组不能开long long,int足矣,把空间开大反而会使时间变慢TLE

#include<cstdio>
#include<iostream>
using namespace std;
const int M=1000000007;
char a[505][505];
int f[2][505][505];
int n;
long long ans;
int main()
{
    cin>>n;
    ans=0;
    for(int i=1;i<=n;i++) scanf("%s",a[i]+1);
    f[0][1][n]=1;
    for(int i=1;i<=n;i++)
    {
        for(int x1=1;x1<=n;x1++)
        if(i+1-x1>=1&&i+1-x1<=n)
        {
            int y1=i+1-x1;
            for(int x2=1;x2<=n;x2++)
            if((n+1)*2-x1-y1-x2>=1&&(n+1)*2-x1-y1-x2<=n)
            {
                int y2=(n+1)*2-x1-y1-x2;
                if(a[x1][y1]==a[x2][y2])
                f[1][x1][x2]=((f[0][x1-1][x2]+f[0][x1-1][x2+1])%M+(f[0][x1][x2]+f[0][x1][x2+1])%M)%M;
            }
        }
        for(int x1=1;x1<=n;x1++)
        for(int x2=1;x2<=n;x2++)
        {
            f[0][x1][x2]=f[1][x1][x2];
            f[1][x1][x2]=0;
        }
    }
    for(int i=1;i<=n;i++) ans=(ans+f[0][i][i])%M;
    cout<<ans<<endl;
    return 0;
}
				







题目描述 牛牛和她的朋友们正在玩一个有趣的游戏,他们需要构建一个有 $n$ 个节点的无向图,每个节点都有一个唯一的编号并且编号从 $1$ 到 $n$。他们需要从节点 $1$ 到节点 $n$ 找到一条最短路径,其中路径长度是经过的边权的和。为了让游戏更有趣,他们决定在图上添加一些额外的边,这些边的权值都是 $x$。他们想知道,如果他们添加的边数尽可能少,最短路径的长度最多会增加多少。 输入格式 第一行包含两个正整数 $n$ 和 $m$,表示节点数和边数。 接下来 $m$ 行,每行包含三个整数 $u_i,v_i,w_i$,表示一条无向边 $(u_i,v_i)$,权值为 $w_i$。 输出格式 输出一个整数,表示最短路径的长度最多会增加多少。 数据范围 $2 \leq n \leq 200$ $1 \leq m \leq n(n-1)/2$ $1 \leq w_i \leq 10^6$ 输入样例 #1: 4 4 1 2 2 2 3 3 3 4 4 4 1 5 输出样例 #1: 5 输入样例 #2: 4 3 1 2 1 2 3 2 3 4 3 输出样例 #2: 2 算法 (BFS+最短路) $O(n^3)$ 我们把问题转化一下,假设原图中没有添加边,所求的就是点 $1$ 到点 $n$ 的最短路,并且我们已经求出了这个最短路的长度 $dis$。 接下来我们从小到大枚举边权 $x$,每次将 $x$ 加入图中,然后再次求解点 $1$ 到点 $n$ 的最短路 $dis'$,那么增加的最短路长度就是 $dis'-dis$。 我们发现,每次加入一个边都需要重新求解最短路。如果我们使用 Dijkstra 算法的话,每次加入一条边需要 $O(m\log m)$ 的时间复杂度,总的时间复杂度就是 $O(m^2\log m)$,无法通过本题。因此我们需要使用更优秀的算法。 观察到 $n$ 的范围比较小,我们可以考虑使用 BFS 求解最短路。如果边权均为 $1$,那么 BFS 可以在 $O(m)$ 的时间复杂度内求解最短路。那么如果我们只是加入了一条边的话,我们可以将边权为 $x$ 的边看做 $x$ 条边的组合,每次加入该边时,我们就在原始图上添加 $x$ 条边,边权均为 $1$。这样,我们就可以使用一次 BFS 求解最短路了。 但是,我们不得不考虑加入多条边的情况。如果我们还是将边权为 $x$ 的边看做 $x$ 条边的组合,那么我们就需要加入 $x$ 条边,而不是一条边。这样,我们就不能使用 BFS 了。 但是,我们可以使用 Floyd 算法。事实上,我们每次加入边时,只有边权等于 $x$ 的边会发生变化。因此,如果我们枚举边权 $x$ 时,每次只需要将边权等于 $x$ 的边加入图中,然后使用 Floyd 算法重新计算最短路即可。由于 Floyd 算法的时间复杂度为 $O(n^3)$,因此总的时间复杂度为 $O(n^4)$。 时间复杂度 $O(n^4)$ 空间复杂度 $O(n^2)$ C++ 代码 注意点:Floyd算法计算任意两点之间的最短路径,只需要在之前的路径基础上加入新的边构成的新路径进行更新即可。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值