POJ3624--Charm Bracelet(dp)

26 篇文章 0 订阅
6 篇文章 0 订阅

Do more with less

Description

Bessie has gone to the mall’s jewelry store and spies a charm bracelet. Of course, she’d like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a ‘desirability’ factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).
Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

Line 1: Two space-separated integers: N and M
Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

思路

基础的01背包,但数据很大,开二维数组会超内存,要进行状态压缩。
dp状态转移方程: dp[j]=max(dp[j],dp[jw[i]]+v[i]);

代码

#include<iostream>
#include<cstdio>
#include<string.h>
using namespace std;
int v[20000];
int dp[20000];
int w[20000];
int n,m;
void package()
{
    int i,j;
    for(i = 1; i <= n; i ++)
        for(j = m; j >= w[i]; j --)
                dp[j] = max(dp[j],dp[j-w[i]]+v[i]);
    printf("%d\n",dp[m]);
}
int main()
{
    memset(dp,0,sizeof(dp));
    scanf("%d %d",&n,&m);
    for(int i = 1 ; i <= n; i ++)
        scanf("%d %d",&w[i],&v[i]);
    package();
}

Hint

做题的时候数组开的很大,其实可以不用这么大,懒得改了……

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值