NOI 7113:Charm Bracelet(DP 01背包)

描述

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N(1 ≤ N≤ 3,402) available charms. Each charm iin the supplied list has a weight Wi(1 ≤ Wi≤ 400), a 'desirability' factor Di(1 ≤ Di≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M(1 ≤ M≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

 

输入Line 1: Two space-separated integers: N and M
Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di输出Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints样例输入

4 6
1 4
2 6
3 12
2 7

样例输出

23

 

经典的01背包问题,但是使用二维数组会WA

 

 

#include<cstdio>
#include<cstring>
#define  max(x,y)  (x)>(y)?(x):(y)
using namespace std;

int n,m;
int value[3500];
int weight[3500];
int matrix[3500][3500];

int main()
{
    scanf("%d%d",&n,&m);
    memset(matrix,0,sizeof(matrix));
    value[0]=weight[0]=0;
    for(int i=1;i<=n;i++)
    {
        scanf("%d%d",&weight[i],&value[i]);
    }

    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=m;j++)
        {
            if(j>=weight[i])
                matrix[i][j]=max(matrix[i-1][j],matrix[i-1][j-weight[i]]+value[i]);
            else
                matrix[i][j]=matrix[i-1][j];
        }

    }

    printf("%d",matrix[n][m]);

   return 0;
}

 

优化如下(来源:http://www.cnblogs.com/ECJTUACM-873284962/p/6815610.html)

 

可以进一步优化内存使用。上面计算f[i][j]可以看出,在计算f[i][j]时只使用了f[i-1][0……j],没有使用其他子问题,因此在存储子问题的解时,只存储f[i-1]子问题的解即可。这样可以用两个一维数组解决,一个存储子问题,一个存储正在解决的子问题。

 

再进一步思考,计算f[i][j]时只使用了f[i-1][0……j],没有使用f[i-1][j+1]这样的话,我们先计算j的循环时,让j=M……1,只使用一个一维数组即可。

for i=1……N

for j=M……1

f[j]=max(f[j],f[j-weight[i]+value[i])

 

AC代码如下:

#include<iostream>
using namespace std;
int f[35000];//全局变量,自动初始化为0
int weight[35000];
int value[35000];
#define  max(x,y)    (x)>(y)?(x):(y)
int main()
{

    int N,M;
    cin>>N;//物品个数
    cin>>M;//背包容量
    for (int i=1;i<=N; i++)
    {
        cin>>weight[i]>>value[i];
    }
    for (int i=1; i<=N; i++)
        for (int j=M; j>=1; j--)
        {
            if (weight[i]<=j)
            {
                f[j]=max(f[j],f[j-weight[i]]+value[i]);
            }
        }

    cout<<f[M]<<endl;//输出最优解
}

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值