POJ_2392 Space Elevator(多重背包)

Space Elevator
Description
The cows are going to space! They plan to achieve orbit by building a sort of space elevator: a giant tower of blocks. They have K (1 <= K <= 400) different types of blocks with which to build the tower. Each block of type i has height h_i (1 <= h_i <= 100) and is available in quantity c_i (1 <= c_i <= 10). Due to possible damage caused by cosmic rays, no part of a block of type i can exceed a maximum altitude a_i (1 <= a_i <= 40000).

Help the cows build the tallest space elevator possible by stacking blocks on top of each other according to the rules.
Input
* Line 1: A single integer, K
* Lines 2..K+1: Each line contains three space-separated integers: h_i, a_i, and c_i. Line i+1 describes block type i.
Output
* Line 1: A single integer H, the maximum height of a tower that can be built
Sample Input
3
7 40 3
5 23 8
2 52 6
Sample Output
48
Hint:
From the bottom: 3 blocks of type 2, below 3 of type 1, below 6 of type 3. Stacking 4 blocks of type 2 and 3 of type 1 is not legal, since the top of the last type 1 block would exceed height 40.
题解:

题意:有k中不同的石头要搭一座尽可能高的石梯,告诉我们石头的高度,数量以及限高。限高的意思就是说每种石头不能超过一个对应的高度。要我们求出石梯最大高度。

这是一道很典型的多重背包,并且V=W,我们可以dp高度的可达。一个额外的条件就是每种石头有一个限高。所以这里我们要在多重背包之前加一个贪心操作,按照限高从低到高排序。因为对于一个固定的高度我们可以选择移动砖块的位置,所以我们应尽可能早的满足上限低的砖块。
代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAX_K 410
#define MAX_A 40010
using namespace std;

struct type
{
    int h;
    int a;
    int c;
    bool operator < (const type &next) const
    {
        return this->a < next.a;
    }
};
int K,result;
type T[MAX_K];
int dp[MAX_A];
//因为V=W我们将上界传进去
void CompletePack(int cost,int sum,int amount);
int main()
{
    cin>>K;
    for( int i = 0; i < K; i++ )
        scanf("%d%d%d",&T[i].h,&T[i].a,&T[i].c);
    sort(T,T+K);
    memset(dp,-1,sizeof(dp));
    dp[0]=1;
    for( int i = 0; i < K; i++ )
        CompletePack(T[i].h,T[i].a,T[i].c);
    result=MAX_A-1;
    while( dp[result] == -1 )
        result--;
    printf("%d\n",result);
    return 0;
}
void CompletePack(int cost,int sum,int amount)
{
    if( cost*amount >= sum )
    {
        for( int j = 0; j <= sum; j++ )
        {
            if( dp[j] == 1 && j+cost <= sum )
                dp[j+cost]=1;
        }
        return ;
    }
    else
    {
        int k = 1;
        while( k < amount )
        {
            for( int j = sum; j >= k*cost; j-- )
            {
                if( dp[j-k*cost] == 1 )
                    dp[j]=1;
            }
            amount-=k;
            k*=2;
        }
        for( int j = sum; j >= amount*cost; j-- )
        {
            if( dp[j-amount*cost] == 1 )
                dp[j]=1;
        }
        return ;
    }
}

另外对于多重V=W的多重背包今天学到了一种更加简便的算法,在dp可达性的情况下是很好用的。但是在V!=W时我觉得还是用传统的方法好一些。新技能GET。

memset(dp,0,sizeof(dp));
dp[0]=1;
for( int i = 0; i < K, i++ )
{
    fill(cnt,cnt+T[i].a,0);
    for( int j=T[i].h; j <= T[i].a; j++ )
    {
        if( !dp[j] && dp[j-T[i].h] && cnt[j-T[i].h] < T[i].c )
        {
            dp[j]=1;
            cnt[j]=cnt[j-T[i].h]+1;
            result=max(result,j);
        }
    }
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值