poj 2392 Space Elevator(多重背包变形)

Space Elevator
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5144 Accepted: 2382

Description

The cows are going to space! They plan to achieve orbit by building a sort of space elevator: a giant tower of blocks. They have K (1 <= K <= 400) different types of blocks with which to build the tower. Each block of type i has height h_i (1 <= h_i <= 100) and is available in quantity c_i (1 <= c_i <= 10). Due to possible damage caused by cosmic rays, no part of a block of type i can exceed a maximum altitude a_i (1 <= a_i <= 40000). 

Help the cows build the tallest space elevator possible by stacking blocks on top of each other according to the rules.

Input

* Line 1: A single integer, K 

* Lines 2..K+1: Each line contains three space-separated integers: h_i, a_i, and c_i. Line i+1 describes block type i.

Output

* Line 1: A single integer H, the maximum height of a tower that can be built

Sample Input

3
7 40 3
5 23 8
2 52 6

Sample Output

48

Hint

OUTPUT DETAILS: 

From the bottom: 3 blocks of type 2, below 3 of type 1, below 6 of type 3. Stacking 4 blocks of type 2 and 3 of type 1 is not legal, since the top of the last type 1 block would exceed height 40.

Source

题目:http://poj.org/problem?id=2392

分析:这题其实就是多重背包加一个排序,先按最高能达到的海拔排序,然后直接多重背包= =

代码:

#include<cstdio>
#include<algorithm>
using namespace std;
const int mm=444;
struct block
{
    int h,a,c;
}g[mm];
bool f[44444];
int i,j,k,n;
bool cmp(block a,block b)
{
    return a.a<b.a;
}
int main()
{
    while(scanf("%d",&n)!=-1)
    {
        for(i=0;i<n;++i)scanf("%d%d%d",&g[i].h,&g[i].a,&g[i].c);
        sort(g,g+n,cmp);
        for(f[0]=1,i=g[n-1].a;i>0;--i)f[i]=0;
        for(i=0;i<n;++i)
            for(j=0;j<g[i].c;++j)
                for(k=g[i].a;k>=g[i].h;--k)
                    f[k]|=f[k-g[i].h];
        for(i=g[n-1].a;i>0;--i)
            if(f[i])break;
        printf("%d\n",i);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值