POJ-2201-Cartesian Tree(笛卡尔树)

Description

Let us consider a special type of a binary search tree, called a cartesian tree. Recall that a binary search tree is a rooted ordered binary tree, such that for its every node x the following condition is satisfied: each node in its left subtree has the key less then the key of x, and each node in its right subtree has the key greater then the key of x. 
That is, if we denote left subtree of the node x by L(x), its right subtree by R(x) and its key by kx then for each node x we have 
  • if y ∈ L(x) then ky < kx 
  • if z ∈ R(x) then kz > kx

The binary search tree is called cartesian if its every node x in addition to the main key kx also has an auxiliary key that we will denote by ax, and for these keys the heap condition is satisfied, that is 
  • if y is the parent of x then ay < ax

Thus a cartesian tree is a binary rooted ordered tree, such that each of its nodes has a pair of two keys (k, a) and three conditions described are satisfied. 
Given a set of pairs, construct a cartesian tree out of them, or detect that it is not possible.

Input

The first line of the input file contains an integer number N -- the number of pairs you should build cartesian tree out of (1 <= N <= 50 000). The following N lines contain two numbers each -- given pairs (ki, ai). For each pair |ki|, |ai| <= 30 000. All main keys and all auxiliary keys are different, i.e. ki != kj and ai != aj for each i != j.

Output

On the first line of the output file print YES if it is possible to build a cartesian tree out of given pairs or NO if it is not. If the answer is positive, on the following N lines output the tree. Let nodes be numbered from 1 to N corresponding to pairs they contain as they are given in the input file. For each node output three numbers -- its parent, its left child and its right child. If the node has no parent or no corresponding child, output 0 instead. 
The input ensure these is only one possible tree.

Sample Input

7
5 4
2 2
3 9
0 5
1 3
6 6
4 11

Sample Output

YES
2 3 6
0 5 1
1 0 7
5 0 0
2 4 0
1 0 0
3 0 0

Source

Northeastern Europe 2002, Northern Subregion


思路:题目中说所有的key值都不一样,因此不会存在NO的情况。直接建树再输出即可。


#include <cstdio>
#include <algorithm>
using namespace std;

struct S{
int id,key,val,parent,l,r;
}node[50005];

bool cmp(struct S a,struct S b)
{
    return a.key<b.key;
}

int stk[50005],top,p[50005],l[50005],r[50005];

void build(int n)//因为已经按key值升序排序了,所以后面加入的节点要么成为某个节点的右儿子,要么让根节点成为自己的左儿子
{
    int i;

    top=0;

    stk[top]=1;

    for(i=2;i<=n;i++)
    {
        while(top>=0 && node[stk[top]].val>node[i].val) top--;

        if(top>-1)//如果找到一个不大于自己的节点,就成为该节点的右儿子,还要注意让该节点原来的右儿子变成自己的左儿子(key比其大并且小于其val)
        {
            node[i].parent=stk[top];
            node[node[stk[top]].r].parent=i;
            node[i].l=node[stk[top]].r;
            node[stk[top]].r=i;
        }
        else//如果没找到不大于自己的节点,就变成新的根
        {
            node[stk[0]].parent=i;
            node[i].l=stk[0];
        }

        stk[++top]=i;
    }
}

int main()
{
    int n,i;

    while(~scanf("%d",&n))
    {
        for(i=1;i<=n;i++)
        {
            scanf("%d%d",&node[i].key,&node[i].val);

            node[i].id=i;

            node[i].parent=node[i].l=node[i].r=0;//初始化
        }

        sort(node+1,node+n+1,cmp);

        build(n);

        for(i=1;i<=n;i++)
        {
            p[node[i].id]=node[node[i].parent].id;
            l[node[i].id]=node[node[i].l].id;
            r[node[i].id]=node[node[i].r].id;
        }

        printf("YES\n");

        for(i=1;i<=n;i++) printf("%d %d %d\n",p[i],l[i],r[i]);
    }
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值