1042. 字符统计(20)

389 篇文章 1 订阅
72 篇文章 0 订阅

1042. 字符统计(20)
时间限制 400 ms 内存限制 65536 kB 代码长度限制 8000 B
判题程序 Standard 作者 CHEN, Yue

请编写程序,找出一段给定文字中出现最频繁的那个英文字母。
输入格式:
输入在一行中给出一个长度不超过1000的字符串。字符串由ASCII码表中任意可见字符及空格组成,至少包含1个英文字母,以回车结束(回车不算在内)。
输出格式:
在一行中输出出现频率最高的那个英文字母及其出现次数,其间以空格分隔。如果有并列,则输出按字母序最小的那个字母。统计时不区分大小写,输出小写字母。
输入样例:
This is a simple TEST. There ARE numbers and other symbols 1&2&3………..
输出样例:
e 7

#define _CRT_SECURE_NO_WARNINGS
#include <iostream>
#include <cstring>
#include <fstream>
#include <string>
#include <cmath>
#include <algorithm>
#include <queue>
#include <map>
using namespace std;

const int MaxN = 1010;

typedef struct
{
    int c;
    char ch;
}Static;
bool isAlpha(char &c)
{
    if ('a' <= c && c <= 'z')
        return true;
    else if ('A' <= c && c <= 'Z')
    {
        c += 32;
        return true;
    }
    return false;
}

bool cmp(Static a, Static b)
{
    return a.c > b.c;
}

bool cmp1(Static a, Static b)
{
    return a.ch < b.ch;
}

int main()
{
#ifdef _DEBUG
    //freopen("data.txt", "r+", stdin);
    fstream cin("data.txt");
#endif // _DEBUG

    map<char, int> stat;
    int N = 1;
    char str[MaxN];
    Static s[130] = { 0 };
    cin.getline(str, MaxN);

    for (int i = 0; str[i]; ++i)
    {
        if (isAlpha(str[i]))
        {
            s[str[i]].c += 1;
            s[str[i]].ch = str[i];
        }
    }

    sort(s, s + 130, cmp);

    for (int i = 0, j = 1; j < 130; ++j, ++i)
    {
        if (s[i].c == s[j].c)
        {
            ++N;
        }
        else
            break;
    }

    sort(s, s + N, cmp1);
    cout << s[0].ch << " " << s[0].c;

#ifdef _DEBUG
    cin.close();
#ifndef _CODEBLOCKS
    std::system("pause");
#endif // !_CODEBLOCKS
#endif // _DEBUG

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值