关于升级python yum报错No module named yum

原创 2015年11月20日 17:45:54
升级python yum报错No module named yum


解决办法:

1:修改yum
# vim /usr/bin/yum
将 #!/usr/bin/python 改成  #!/usr/bin/python2.6   版本号根据自己机器修改(本人修改后仍不能使用)

2:重新安装低版python和yum
打开安装盘在Packages下找到一下软件,版本根据自己机器来:

python-2.6.6-51.el6.x86_64.rpm        
python-libs-2.6.6-51.el6.x86_64.rpm       
yum-3.2.29-40.el6.centos.noarch.rpm
python-devel-2.6.6-51.el6.x86_64.rpm  
python-urlgrabber-3.9.1-9.el6.noarch.rpm

移动到一处,这里我放在一起
mkdir /usr/local/src/Python-2.6.6
mv
rpm -Uvh --replacepkgs *.rpm //试过 无效
rpm -ivh --replacepkgs *.rpm //试过 无效
rpm -ivh --force *.rpm //强制安装

此问题本是解决gdb调试run命令时报:Missing separate debuginfos, use: debuginfo-install
一直使用yum安装解决依赖问题,淡忘了rpm 这里在复习一下 centos软件安装命令

版权声明:本文为博主原创文章,未经博主允许不得转载。

相关文章推荐

CentOS6.5 安装Python2.7后, yum出现“No module named yum”错误

安装如下方法安装python2.7: yum install –y python27 python27-devel python-docutils cd /usr/bin/ rm ...
  • Alsmile
  • Alsmile
  • 2014年03月08日 00:24
  • 12632

python升级导致yum命令无法使用的解决办法(修改版)

1、报错信息如下: [root@develop bin]# yum [root@develop local]# yum -y install prce There was a problem imp...
  • EI__Nino
  • EI__Nino
  • 2013年01月11日 23:23
  • 55776

运行yum报错:No module named yum

问题系统版本:Red Hat Enterprise Linux Server release 6.2 (Santiago) 内核版本:2.6.32-220.el6.x86_64报错情况:There ...

python 报错 ImportError: No module named setuptools

python 报错 ImportError: No module named setuptools报错描述 初学Python,在windows下装个pip,然后就各种报错报错报错,报错显示的是*...
  • cfylove
  • cfylove
  • 2015年08月04日 17:11
  • 771

关于linux下python 报错:‘ImportError: No module named’ 的问题

运行一个简单的python脚本如下:--encoding:utf-8--import unittest,sys,paramiko sys.path.append(“/data/CFDautotest...

解决python安装selenium报错问题ImportError: No module named 'selenium'

1.      ImportError: No module named'selenium' Selenium不能通过pip install -U selenium安装,报错,安装失败 解决方...

ubuntu上跑python连接pg,报错 ImportError: No module named psycopg2

ubuntu上跑python连接pg,报错  ImportError: No module named psycopg2 root@pgproxy1:~# python /home/zxw/PGW...

解决centos6上python升级混乱导致yum报错

转自:http://www.linuxdiyf.com/linux/27055.html 亲测方法二解决问题 由于服务器centos6.8安装tensorflow,安装Python版本过多...

关于centos7.2 升级Python之后yum报错的问题

从昨天晚上到现在我这一直在为这件事在度娘,但是没有什么好的答案。 所以呢我就准备自己着手在看一下。果不其然通过自己的一点一点的测试果然啊是可以运行yum了,就连pip也随之弄好了。[root@hanx...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:关于升级python yum报错No module named yum
举报原因:
原因补充:

(最多只允许输入30个字)