E - Leading and Trailing (快速幂+double)

You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of nk.
Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing two integers: n (2 ≤ n < 231) and k (1 ≤ k ≤ 107).
Output

For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such that nk contains at least six digits.
Sample Input

5

123456 1

123456 2

2 31

2 32

29 8751919

Sample Output

Case 1: 123 456

Case 2: 152 936

Case 3: 214 648

Case 4: 429 296

Case 5: 665 669

对于这道题目,后三位数很好算,快速幂取模就可以。
前三位,由于数据太大,可以转化成double 类型,然后每次取前三位。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
using namespace std;
double change(double a)//取double类型数据的前三位
{
   while(a>=1000.0)
   {
      a /= 10.0;
   }
   return a;
}
long long int Pow(long long int a, long long int b)//快速幂,a的b次方
{
   long long int r = 1, base = a;
   while(b)
   {
      if(b%2)
      {
         r = (r * base) % 1000;
      }
      base = (base * base) % 1000;
      b /= 2;
   }
   return r;
}
int main()
{
   int T;
   long long int n, m;
   int s1;
   scanf("%d", &T);
   for(int t=1;t<=T;t++)
   {
      scanf("%lld %lld", &n, &m);
      s1 = Pow(n, m);//取到后三位
      double k = 1.0 * n, ka = 1.0;
      while(m)//快速幂
      {
         if(m % 2)
         {
            ka *= k;
            ka = change(ka);//取前三位
         }
         k *= k;
         k = change(k);//取前三位
         m /= 2;
      }
      printf("Case %d: %03d %03d\n", t, (int)ka, s1);//注意可能会出现012这样的情况
   }
   return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值