Leading and Trailing(快速幂)
You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of nk.
Input
Input starts with an integer T (≤ 1000), denoting the number of test cases.
Each case starts with a line containing two integers: n (2 ≤ n < 231) and k (1 ≤ k ≤ 107).
Output
For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such that nk contains at least six digits.
Sample Input
5
123456 1
123456 2
2 31
2 32
29 8751919
Sample Output
Case 1: 123 456
Case 2: 152 936
Case 3: 214 648
Case 4: 429 296
Case 5: 665 669
题意: 就是求n^k的前三位和后三位
思路:
前三位
要用到数学思想,x=10log10(x),我们假设nk =10x ,那么x=log10(nk),即x=k*log10(n),此时计算出的x是double型的,而10x = 10a *10b (a表示次方的整数部分,b表示次方的小数部分),我们不难看出10a 的作用只是把10b 向右移动a位罢了,前三位在10b 中,而100 =1,101 =10,故100.xxxx 不会超过10,即小数点前必只有一位,所以我们只需把计算结果向右移两位即可得到前三位。
后三位
需要用到快速幂,具体看这里,很详细
AC代码:
#include<stdio.h>
#include<string.h>
#include<math.h>
long long t,n,k,d,c;
int init()//后三位
{
d=1;c=n%1000;
while(k)
{
if(k%2==1)//如果k为奇数 指数-1再缩为一半
d=d*c%1000;//此时要收集减掉的一次方
k/=2;//指数缩小为一半 k减不减一不影响结果 如5/2=(5-1)/2
c=c*c%1000;//底数变为原来的平方
}
return d;
}
int main()
{
long long i,j,z=0;
double x,s;
scanf("%lld",&t);
while(t--)
{
z++;
scanf("%lld%lld",&n,&k);
x=(double)k*log10(n*1.0);//记n^k=10^x,则x=log10(n^k),即x=k*log10(n);
//x可分为整数部分a和小数部分b,即10^x=10^a*10^b
x=x-(int)x;//小数部分b
s=pow(10,x);//10^b
int ss=(int)(s*100);//后移两位,得三位整数
printf("Case %d: %03d %03lld\n",z,ss,init());
}
return 0;
}