快速幂(前三个数,后三个数)

You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of nk.

Input
Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing two integers: n (2 ≤ n < 231) and k (1 ≤ k ≤ 107).

Output
For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such that nk contains at least six digits.

Sample Input
5
123456 1
123456 2
2 31
2 32
29 8751919
Sample Output
Case 1: 123 456
Case 2: 152 936
Case 3: 214 648
Case 4: 429 296
Case 5: 665 669

翻译:给你两个整数:n和k,你的任务是找出nk的最高有效的三位数和最低有效的三位数。

输入
输入以整数T开始(≤ 1000),表示测试用例的数量。
每种情况都从包含两个整数的行开始:n(2≤ n<231)和k(1≤ k≤ 107).
输出
对于每个案例,打印案例编号、三个前导数字(最高有效)和三个后尾数字(最低有效)。您可以假设给定的输入使得n的k次方至少包含六位数字。
样本输入
5
123456 1
123456 2
2 31
2 32
29 8751919
样本输出
案例1:123 456
案例2:152 936
案例3:214 648
案例4:429 296
案例5:665 669

题解:后三位,快速幂模板,前三位如下图所示

在这里插入图片描述

#include<stdio.h>
#include<math.h>
int main()
{
	int t,q=1;
	scanf("%d",&t);
	while(t--)
	{
		long long n,m;
		scanf("%lld%lld",&n,&m);
		double k=m*log10(n);//小数部分
		int x=k,p;//x为整数部分
		p=pow(10,k-x)*100;
		printf("Case %d: %03d",q++,p);
		int u=1;
		while(m)
		{
			if(m%2!=0)
			u=u*n%1000;
			n=n*n%1000;
			m=m/2;
		}
		printf(" %03d\n",u);
		 
	}
 } 
//

快速幂模板

int s(int m, int k, int p)
{
    int res=1%p,t=m;
    while (k)
    {
        if (k&1) 
		res=res*t%p;
        t=t*t%p;
        k=k/2;
    }
    return res;
}

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值