Poj 3254 Corn Fields (状压dp初开始)

Corn Fields
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 14540 Accepted: 7621
Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can’t be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers: M and N
Lines 2..M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)
Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.
Sample Input

2 3
1 1 1
0 1 0
Sample Output

9

题意:给你n行, m列,由数字0, 1 组成,0表示没有草, 1表示有草,只有 1 上面可以有牛,而牛不能相邻,让你求不相邻牛的排列种数
题解:状压dp一般需要有二进制的配合,二进制可以很好的表示有无状态,对于一行用二进制表示可以准确的表达出该行有没有草,然后从第一行开始求牛的排列,一层一层往上面推理就好,细节见代码。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define M (1<<14)
#define N 20
#define MOD 100000000
#define MEM(a, b) memset(a, b, sizeof(a))

int dp[N][M], mp[M], st[M];
bool judge(int x)
{
    return (x & (x<<1));
}
bool judge2(int i, int j)
{
    return (mp[i] & st[j]);
}
int main()
{
    int n, m, x;
    while(scanf("%d%d", &n, &m) != EOF)
    {
        MEM(mp, 0);
        MEM(st, 0);
        MEM(dp, 0);
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<m; j++)
            {
                scanf("%d", &x);
                if(!x)
                {
                    mp[i] += (1<<j);
                }
            }
        }
        int top = 0;
        for(int i=0; i<(1<<m); i++)
        {
            if(!judge(i))//判断这样放牛的方法是否可行
            {
                st[top++] = i;//这个表示一行可以放牛的所有可能
            }
        }
        for(int i=0; i<top; i++)//第一行特殊考虑
        {
            if(!judge2(0, i))
            {
                dp[0][i] = 1;
            }
        }
        for(int i=1; i<n; i++)
        {
            for(int j=0; j<top; j++)//表示要排的这一行 
            {
                if(judge2(i, j))
                {
                    continue;
                }
                for(int k=0; k<top; k++)//表示上一行 
                {
                    if(judge2(i-1, k))
                    {
                        continue;
                    }
                    if(!(st[j] & st[k]))
                    {
                        dp[i][j] += dp[i-1][k];//加上 上面总的的排列个数 
                    }
                }
            }
        }
        int ans = 0;
        for(int i=0; i<top; i++)
        {
            ans += dp[n-1][i];
            ans %= MOD;
        }
        printf("%d\n", ans);
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值