POJ-3687-Labeling Balls

Labeling Balls
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14167 Accepted: 4117

Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

  1. No two balls share the same label.
  2. The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".

Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, bN) There is a blank line before each test case.

Output

For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.

Sample Input

5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2

Sample Output

1 2 3 4
-1
-1
2 1 3 4
1 3 2 4

Source



解题思路:
     将输入的n行建立有向图,如果该图产生回路,那么输出-1,如果不产生回路,重量 从高到低依次选择可以选择的最大编号
    每次找出入度为0的点,为了防止重复计算,入度为0的点也要--;这样就为-1了。
    每次找,最后输出就可以了
     两组比较好的测试案例:
     第二个测试案例有5个,但是有2个一样的,所以按 4 个算

C++ 源代码

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
using namespace std;
const int MAX = 210;
int map[MAX][MAX],indegree[MAX],ans[MAX];
int n,m;

int main()
{
    int i,j,k;
    int u,v;
    int t;
    cin>>t;
    while(t--)
    {
        scanf("%d %d",&n,&m);
        memset(map,0,sizeof(map));
        memset(indegree,0,sizeof(indegree));
        for(i=0;i<m;i++)
        {
            scanf("%d %d",&u,&v);
            if(!map[v][u])      //反向建图
            {
                map[v][u]=1;
                indegree[u]++;
            }
        }

        for(i=n;i>=1;i--)    //i 表示重量 从高到低依次选择可以选择的最大编号
        {
            for(j=n;j>=1;j--)  //j 表示每次可能选出的(即出度为0)最大编号,那么该编号一定能够排在其他所有编号的后边,
            {                   //找出度为0的最大编号使其分配最大的重量,那么最后找出的解一定是最优解。
                if(indegree[j]==0)
                {
                    indegree[j]--;
                    ans[j]=i;

                    for(k=1;k<=n;k++)
                        if(map[j][k]==1)
                            indegree[k]--;
                        break;
                }
            }
            if(j<1)
                break;
        }
        if(i>=1)
            cout<<"-1\n";
        else
        {
            for(i=1;i<n;i++)
                cout<<ans[i]<<" ";
            cout<<ans[n]<<endl;
        }
    }
    return 0;  
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值