Labeling Balls(POJ--3687

Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

  1. No two balls share the same label.
  2. The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".

Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.

Output

For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.

题意:总共有T组数据,每组输入n和m,分别表示有n个小球和m条两个小球之间的关系,接下来输入m行,每行中有a,b两个数字代表a号球比b号球轻,最后按重量从小到大的顺序输出小球编号。

思路:在有多种答案的情况下如果是建正向图则最后结果不符合要求,题目中要求如果有多种答案则按重量的字典序排序而不是按编号的字典序排序,所以该题应当建逆向图。

Sample Input

5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2

Sample Output

1 2 3 4
-1
-1
2 1 3 4
1 3 2 4

#include <cstdio>
#include <queue>
#include <cstring>
#define MAX 100002
using namespace std;
int mmap[205][205];
int in[205],n,a[205];
int topo()
{
    int flag,k;
    for(int i=n; i>=1; i--)
    {
        flag=1;                           //假设成环
        for(int j=n; j>=1; j--)
        {
            if(!in[j])
            {
                in[j]=-1;
                k=j;
                a[j]=i;                 //越是重的入度数先为0,则排序越在后边
                flag=0;               //表示此时未成环
                break;
            }
        }
        if(flag)                         //如果成环直接返回0
            return 0;
        for(int j=n; j>=1; j--)
        {
            if(mmap[k][j])
            {
                in[j]-=mmap[k][j];
            }
        }
    }
    return 1;
}
int main()
{
    //freopen("oo.text","r",stdin);
    int T,m,x,y,flag;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d %d",&n,&m);
        memset(mmap,0,sizeof(mmap));
        memset(in,0,sizeof(in));
        memset(a,0,sizeof(a));
        for(int i=0; i<m; i++)
        {
            scanf("%d %d",&x,&y);
            mmap[y][x]++;               //逆向建图
            in[x]++;
        }
        flag=topo();
        if(flag)
        {
            for(int i=1; i<=n; i++)
                printf("%d%c",a[i],i==n?'\n':' ');
        }
        else
            printf("-1\n");
    }
    return 0;
}<strong>
</strong>
特殊样例(如果是正向建图下边的样例就过不了):
2 
5 4
5 1
4 2
1 3
2 3
 
10 5
4 1
8 1
7 8
4 1
2 8
 
ans:
2 4 5 3 1        逆向建图
5 1 6 2 7 8 3 4 9 10  没有判重边的话就输出 -1

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值