poj 3481 Double Queue splay

Double Queue
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10244 Accepted: 4651

Description

The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing environment provided by IBM Romania, and using modern information technologies. As usual, each client of the bank is identified by a positive integer K and, upon arriving to the bank for some services, he or she receives a positive integer priorityP. One of the inventions of the young managers of the bank shocked the software engineer of the serving system. They proposed to break the tradition by sometimes calling the serving desk with thelowest priority instead of that with the highest priority. Thus, the system will receive the following types of request:

0The system needs to stop serving
1 K PAdd client K to the waiting list with priority P
2Serve the client with the highest priority and drop him or her from the waiting list
3Serve the client with the lowest priority and drop him or her from the waiting list

Your task is to help the software engineer of the bank by writing a program to implement the requested serving policy.

Input

Each line of the input contains one of the possible requests; only the last line contains the stop-request (code 0). You may assume that when there is a request to include a new client in the list (code 1), there is no other request in the list of the same client or with the same priority. An identifier K is always less than 106, and a priorityP is less than 107. The client may arrive for being served multiple times, and each time may obtain a different priority.

Output

For each request with code 2 or 3, the program has to print, in a separate line of the standard output, the identifier of the served client. If the request arrives when the waiting list is empty, then the program prints zero (0) to the output.

Sample Input

2
1 20 14
1 30 3
2
1 10 99
3
2
2
0

Sample Output

0
20
30
10
0

题意:给三种操作,插入一个节点,p是优先级,k是客户编号,

删除一个优先级最大的节点

删除一个优先级最小的节点


做法有很多,因为学习splay,水了一下。

以前以为splay很高大上,这两天看了看,感觉和以前数据结构里学的二叉平衡树,b+,b-树的难度没多大区别,不过用法有很多,的要慢慢学

水下代码




#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
#define maxn 1000001
int ch[maxn][2],val[maxn],fa[maxn],id[maxn],root;
int cnt = 0;
int newnode(int k,int p){
    val[cnt]=p;
    id[cnt]=k;
    ch[cnt][0]=ch[cnt][1]=0;
    return cnt++;
}
void init(){
    root = 0;
    cnt = 1;
    ch[0][0] = ch[0][1] = fa[0] = 0;
}
void rotate(int n){
    int f = fa[n],ff=fa[f];
    int x = (ch[f][1] == n),x1=(ch[ff][1]==f);
    ch[ff][x1] = n;
    ch[f][x] = ch[n][!x];
    ch[n][!x] = f;
    fa[ch[f][x]] = f;
    fa[n] = ff;
    fa[f] = n;
}
void splay(int n,int p){
    while(fa[n] != p){
        int f = fa[n],ff=fa[f];
        if(ff==p)rotate(n);
        else if((ch[ff][1] == f)==(ch[f][1]==n))rotate(f),rotate(n);
        else rotate(n),rotate(n);
    }
}
int findmax(int n){
    while(ch[n][1] != 0) n=ch[n][1];
    return n;
}
int findmin(int n){
    while(ch[n][0] != 0) n=ch[n][0];
    return n;
}
int jion(int p,int q,int f){
    if(p == 0) return q;
    int m = findmax(p);
    splay(m,f);
    ch[m][1] = q;
    fa[q]=m;
    return m;
}
void add(int k,int p){
    int q = newnode(k,p);
    if(ch[root][1] == 0) ch[root][1] = q,fa[q]=root;
    else {
        int x = ch[root][1],y=x;
        while(x){
            y = x;
            if(val[x]>p) x=ch[x][0];
            else x=ch[x][1];
        }
        if(val[y] > p) ch[y][0]=q,fa[q]=y;
        else ch[y][1] = q,fa[q]=y;
        ///splay(q,root);
    }
}
void drop(int n){
    if(n==0){
        printf("0\n");
        return ;
    }
    printf("%d\n",id[n]);
    splay(n,root);
    int p = jion(ch[n][0],ch[n][1],n);
    ch[root][1] = p;
    fa[p] = root;
}

int main(){
    int n,p,k;
    init();
    while(scanf("%d",&n),n){
        if(n == 2)    drop(findmax(ch[root][1]));
        else if(n ==3)drop(findmin(ch[root][1]));
        else {
            scanf("%d%d",&k,&p);
            add(k,p);
        }
    }
    return 0;
}
















  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

GDRetop

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值