hdu 5289 Assignment 2015 Multi-University Training Contest 1

这篇博客介绍了HDU 5289 Assignment问题的解决方案,该问题涉及计算满足最大值减去最小值小于k的区间数量。解题策略包括从每个位置开始枚举,使用二分查找确定最右侧位置,并应用树状数组优化以高效地更新最大值和最小值。
摘要由CSDN通过智能技术生成

Assignment

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 86    Accepted Submission(s): 43


Problem Description
Tom owns a company and he is the boss. There are n staffs which are numbered from 1 to n in this company, and every staff has a ability. Now, Tom is going to assign a special task to some staffs who were in the same group. In a group, the difference of the ability of any two staff is less than k, and their numbers are continuous. Tom want to know the number of groups like this.
 

Input
In the first line a number T indicates the number of test cases. Then for each case the first line contain 2 numbers n, k (1<=n<=100000, 0<k<=10^9),indicate the company has n persons, k means the maximum difference between abilities of staff in a group is less than k. The second line contains n integers:a[1],a[2],…,a[n](0<=a[i]<=10^9),indicate the i-th staff’s ability.
 

Output
For each test,output the number of groups.
 

Sample Input
  
  
2 4 2 3 1 2 4 10 5 0 3 4 5 2 1 6 7 8 9
 

Sample Output
  
  
5 28
Hint
First Sample, the satisfied groups include:[1,1]、[2,2]、[3,3]、[4,4] 、[2,3]
 

Source



算出有多少个区间。满足最大值-最小值 < k

解法:

枚举每个位置x是区间的最左边位置。二分查找,最右的位置r,满足[x,r]的最大值-最小值恰好 < k

r-x+1就是解

用树状数组更新最大最小值,二分位置。





#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
using namespace std;
#define maxn 100007
int tree1[maxn];
int tree2[maxn];
int lowbit(int i){
    return i&(-i);
}
void addmax(int p,int num){
    while(p < maxn){
        tree1[p] = max(tree1[p],num);
        p += lowbit(p);
    }
}

int querymax(int p){
    int ans = 0;
    while(p > 0){
        ans = max(ans,tree1[p]);
        p -= lowbit(p);
    }
    return ans;
}

void addmin(int p,int num){
    while(p < maxn){
        tree2[p] = min(tree2[p],num);
        p += lowbit(p);

    }
}
int querymin(int p){
    int ans = 1000000007;
    while(p > 0){
        ans = min(ans,tree2[p]);
        p -= lowbit(p);
    }
    return ans;

}

int num[maxn];
int main(){
    int t,n,k;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&k);
        for(int i = 1;i <= n; i++){
            scanf("%d",&num[i]);
        }
        memset(tree1,0,sizeof(tree1));
        memset(tree2,0x3f,sizeof(tree2));
        long long ans = 0;
        for(int i = n; i > 0 ; i--){
            addmax(i,num[i]);
            addmin(i,num[i]);
            int low = i,high = n;
            while(low <= high){
                int mid = (low+high)/2;
                int ma = querymax(mid);
                int mi = querymin(mid);
                if(ma - mi >= k)
                    high = mid-1;
                else
                    low = mid+1;
            }
            ans += low-i;
            //cout<<low<<endl;
        }
        cout<<ans<<endl;
    }
    return 0;
}

















评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

GDRetop

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值