poj 1408 Fishnet(直线方程、交点、三角形面积的应用)

Fishnet
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 1294 Accepted: 818

Description

A fisherman named Etadokah awoke in a very small island. He could see calm, beautiful and blue sea around the island. The previous night he had encountered a terrible storm and had reached this uninhabited island. Some wrecks of his ship were spread around him. He found a square wood-frame and a long thread among the wrecks. He had to survive in this island until someone came and saved him. 

In order to catch fish, he began to make a kind of fishnet by cutting the long thread into short threads and fixing them at pegs on the square wood-frame. He wanted to know the sizes of the meshes of the fishnet to see whether he could catch small fish as well as large ones. 

The wood frame is perfectly square with four thin edges on meter long: a bottom edge, a top edge, a left edge, and a right edge. There are n pegs on each edge, and thus there are 4n pegs in total. The positions of pegs are represented by their (x,y)-coordinates. Those of an example case with n=2 are depicted in figures below. The position of the ith peg on the bottom edge is represented by (ai,0). That on the top edge, on the left edge and on the right edge are represented by (bi,1), (0,ci) and (1,di), respectively. The long thread is cut into 2n threads with appropriate lengths. The threads are strained between (ai,0) and (bi,1),and between (0,ci) and (1,di) (i=1,...,n). 

You should write a program that reports the size of the largest mesh among the (n+1)2 meshes of the fishnet made by fixing the threads at the pegs. You may assume that the thread he found is long enough to make the fishnet and the wood-frame is thin enough for neglecting its thickness. 
 

Input

The input consists of multiple sub-problems followed by a line containing a zero that indicates the end of input. Each sub-problem is given in the following format. 

a1 a2 ... an 
b1 b2 ... bn 
c1 c2 ... cn 
d1 d2 ... dn 
you may assume 0 < n <= 30, 0 < ai,bi,ci,di < 1

Output

For each sub-problem, the size of the largest mesh should be printed followed by a new line. Each value should be represented by 6 digits after the decimal point, and it may not have an error greater than 0.000001.

Sample Input

2
0.2000000 0.6000000
0.3000000 0.8000000
0.1000000 0.5000000
0.5000000 0.6000000
2
0.3333330 0.6666670
0.3333330 0.6666670
0.3333330 0.6666670
0.3333330 0.6666670
4
0.2000000 0.4000000 0.6000000 0.8000000
0.1000000 0.5000000 0.6000000 0.9000000
0.2000000 0.4000000 0.6000000 0.8000000
0.1000000 0.5000000 0.6000000 0.9000000
2
0.5138701 0.9476283
0.1717362 0.1757412
0.3086521 0.7022313
0.2264312 0.5345343
1
0.4000000
0.6000000
0.3000000
0.5000000
0

Sample Output

0.215657
0.111112
0.078923
0.279223
0.348958

Source

题目:http://poj.org/problem?id=1408

分析:这题要求最大的四边形面积,四边形的面积可以化成两个三角形面积的和,只要求出所有网线的交点,还有网线与框的交点,然后枚举四个点,求面积,然后取最值。。。详细见代码

代码:

#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
double a[55],b[55],c[55],d[55],a1[55],b1[55],c1[55],a2[55],b2[55],c2[55];
double x[55][55],y[55][55];
double ans;
int i,j,k,n;
void line(double x1,double y1,double x2,double y2,double &a,double &b,double &c)
{
    a=y1-y2,b=x2-x1,c=x1*y2-x2*y1;
}
double sqr(double a)
{
    return a*a;
}
double dis(double x1,double y1,double x2,double y2)
{
    return sqrt(sqr(x1-x2)+sqr(y1-y2));
}
double s(double x1,double y1,double x2,double y2,double x3,double y3)
{
    double a,b,c,p;
    a=dis(x1,y1,x2,y2);
    b=dis(x1,y1,x3,y3);
    c=dis(x2,y2,x3,y3);
    p=(a+b+c)/2.0;
    return sqrt(p*(p-a)*(p-b)*(p-c));
}
double area(int i,int j)
{
    return s(x[i][j],y[i][j],x[i][j-1],y[i][j-1],x[i-1][j],y[i-1][j])+
           s(x[i-1][j-1],y[i-1][j-1],x[i][j-1],y[i][j-1],x[i-1][j],y[i-1][j]);
}
int main()
{
    while(scanf("%d",&n),n++)
    {
        for(i=1;i<n;++i)scanf("%lf",&a[i]);
        for(i=1;i<n;++i)scanf("%lf",&b[i]);
        for(i=1;i<n;++i)scanf("%lf",&c[i]);
        for(i=1;i<n;++i)scanf("%lf",&d[i]);
        for(i=1;i<n;++i)
        {
            line(0,c[i],1,d[i],a1[i],b1[i],c1[i]);
            line(a[i],0,b[i],1,a2[i],b2[i],c2[i]);
        }
        for(i=1;i<n;++i)
        {
            x[0][i]=a[i],y[0][i]=0;
            x[n][i]=b[i],y[n][i]=1;
        }
        for(i=1;i<n;++i)
        {
            x[i][0]=0,y[i][0]=c[i];
            x[i][n]=1,y[i][n]=d[i];
        }
        x[0][0]=y[0][0]=0;
        x[n][n]=y[n][n]=1;
        x[n][0]=0,y[n][0]=1;
        x[0][n]=1,y[0][n]=0;
        for(i=1;i<n;++i)
            for(j=1;j<n;++j)
            {
                x[i][j]=(b2[j]*c1[i]-b1[i]*c2[j])/(a2[j]*b1[i]-a1[i]*b2[j]);
                y[i][j]=-(a1[i]*x[i][j]+c1[i])/b1[i];
            }
        ans=0;
        for(i=1;i<=n;++i)
            for(j=1;j<=n;++j)
                ans=max(ans,area(i,j));
        printf("%.6lf\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值