uva 120 - Stacks of Flapjacks


 Stacks of Flapjacks 

Background

Stacks and Queues are often considered the bread and butter of data structures and find use in architecture, parsing, operating systems, and discrete event simulation. Stacks are also important in the theory of formal languages.

This problem involves both butter and sustenance in the form of pancakes rather than bread in addition to a finicky server who flips pancakes according to a unique, but complete set of rules.

The Problem

Given a stack of pancakes, you are to write a program that indicates how the stack can be sorted so that the largest pancake is on the bottom and the smallest pancake is on the top. The size of a pancake is given by the pancake's diameter. All pancakes in a stack have different diameters.

Sorting a stack is done by a sequence of pancake ``flips''. A flip consists of inserting a spatula between two pancakes in a stack and flipping (reversing) the pancakes on the spatula (reversing the sub-stack). A flip is specified by giving the position of the pancake on the bottom of the sub-stack to be flipped (relative to the whole stack). The pancake on the bottom of the whole stack has position 1 and the pancake on the top of a stack ofn pancakes has position n.

A stack is specified by giving the diameter of each pancake in the stack in the order in which the pancakes appear.

For example, consider the three stacks of pancakes below (in which pancake 8 is the top-most pancake of the left stack):

         8           7           2
         4           6           5
         6           4           8
         7           8           4
         5           5           6
         2           2           7

The stack on the left can be transformed to the stack in the middle via flip(3). The middle stack can be transformed into the right stack via the commandflip(1).

The Input

The input consists of a sequence of stacks of pancakes. Each stack will consist of between 1 and 30 pancakes and each pancake will have an integer diameter between 1 and 100. The input is terminated by end-of-file. Each stack is given as a single line of input with the top pancake on a stack appearing first on a line, the bottom pancake appearing last, and all pancakes separated by a space.

The Output

For each stack of pancakes, the output should echo the original stack on one line, followed by some sequence of flips that results in the stack of pancakes being sorted so that the largest diameter pancake is on the bottom and the smallest on top. For each stack the sequence of flips should be terminated by a 0 (indicating no more flips necessary). Once a stack is sorted, no more flips should be made.

Sample Input

1 2 3 4 5
5 4 3 2 1
5 1 2 3 4

Sample Output

1 2 3 4 5
0
5 4 3 2 1
1 0
5 1 2 3 4
1 2 0

英文看不懂百度了中文意思:

给你一叠薄煎饼,请你写一个程序来指出要如何安排才能使这些薄煎饼由上到下依薄煎饼的半径由小到大排好。所有的薄煎饼半径均不相同。要把薄煎饼排好序需要对这些薄煎饼做翻面(flip)的动作。方法是以一抹刀插入一叠薄煎饼中,然后做翻面的动作(也就是说在抹刀上面的薄煎饼经翻 面后,会依相反的次序排列)。若一叠共有n个薄煎饼,我们定义最底下的薄煎饼的位置为1,最上面的薄煎饼位置为n。当抹刀插入位置为k时,代表从位置k 位置n的薄煎饼要做翻面的动作。一开始时,这叠薄煎饼随意堆放,并以半径大小来表示。

大意就是按照题目所给的方法排序并输出排序的过程。

题目的排序方法就是每次可以任意选个地方然后从头开始到这个地方翻转一下,

题目中的编号是逆序的即第一个为n最后一个为1

5 1 2 3 4

先选取第一个就是从4到开头翻转变为4 3 2 1 5然后选第二个1然后翻转下1 2 3 4 5.

类似于选择排序,每次把要排的那个数字先翻转到开头,然后选择末尾第一个未排序的翻转,这样这个元素就排好位置了。

实现过程就是每次找到当前最大的元素,如果他在排完序后的位置则不用排序,否则翻转到开头然后翻转到他排完序后的位置,因为是每次排当前最大的所以排完序后的位置我们是知道第一次在n,第二次在n-1一次类推。

 

需要注意的是。首先待排序的数字是不连续的开始以为连续的,直接位置就是他的标号了 。还有可能有重复元素。

 

#include <stdio.h>
int getmax(int a[],int pos)
{int max=pos,i;
 for (i=1;i<pos;i++)
 if (a[i]>a[max]) max=i;
 return max;
};
void main()
{int a[101],b[101],c[2000],step,i,j,num=1,max,pos;
 while (scanf("%d",&a[num])!=EOF)
 {
  while (getchar()!='\n')
  {++num;scanf("%d",&a[num]);}
  for (i=1;i<num;i++)
  printf("%d ",a[i]);
  printf("%d\n",a[num]);
  pos=num; step=0;
  while (pos>0)
  {max=getmax(a,pos);
   if (max<pos)
   {if (max!=1) {++step; c[step]=num+1-max;}
    for (i=1;i<=max;i++)
 b[max-i+1]=a[i];
 for (i=1;i<=max;i++)
    a[i]=b[i];
  
    for (i=1;i<=pos;i++)
 b[pos-i+1]=a[i];
 for (i=1;i<=pos;i++)
    a[i]=b[i];
 ++step;  c[step]=num-pos+1;
   }
   --pos;
  }
  for (i=1;i<=step;i++)
  printf("%d ",c[i]);
  printf("0\n");
  num=1;
 }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值