hdu 1677 Nested Dolls【贪心解嵌套娃娃问题】

67 篇文章 0 订阅
15 篇文章 0 订阅

链接:





Nested Dolls

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1876    Accepted Submission(s): 524


Problem Description
Dilworth is the world’s most prominent collector of Russian nested dolls: he literally has thousands of them! You know, the wooden hollow dolls of different sizes of which the smallest doll is contained in the second smallest, and this doll is in turn contained in the next one and so forth. One day he wonders if there is another way of nesting them so he will end up with fewer nested dolls? After all, that would make his collection even more magnificent! He unpacks each nested doll and measures the width and height of each contained doll. A doll with width w1 and height h1 will fit in another doll of width w2 and height h2 if and only if w1 < w2 and h1 < h2. Can you help him calculate the smallest number of nested dolls possible to assemble from his massive list of measurements?
 

Input
On the first line of input is a single positive integer 1 <= t <= 20 specifying the number of test cases to follow. Each test case begins with a positive integer 1 <= m <= 20000 on a line of itself telling the number of dolls in the test case. Next follow 2m positive integers w1, h1,w2, h2, . . . ,wm, hm, where wi is the width and hi is the height of doll number i. 1 <= wi, hi <= 10000 for all i.
 

Output
For each test case there should be one line of output containing the minimum number of nested dolls possible.
 

Sample Input
       
       
4 3 20 30 40 50 30 40 4 20 30 10 10 30 20 40 50 3 10 30 20 20 30 10 4 10 10 20 30 40 50 39 51
 

Sample Output
       
       
1 2 3 2
 

Source
 

Recommend
lcy


 



题意:


      给你 N 个娃娃, 每个娃娃有特定的 w 和 h
      当且仅当 d1.w < d2.w && d1.h < d2.h , d1 才可以放入 d2中
      问:最少还可以剩下几个娃娃

算法:应该是要用 dp 做了,这里用贪心Orz

          最后发现都一样,贪心还是 DP , 分析了 hdu 1257 就知道了Orz


思路:


      感觉类似于hdu 1257 最少拦截系统  的非DP解法【贪心求解】 hdu 1257 题解
      先对娃娃们排序:先按照 w 从大到小排序, w 相同,则按照 h 从小到大排序

关于排序:


           先按照 w 从大到小排序可以理解吧【把小的嵌套到大的当中去】
           对于 w 相同时 h 从小到大排序
           如果 m 个 w 相同, 那么必然是嵌套在 m 个不同的娃娃中
          【可能是比它大的,也可能是它本身】
           先选择 h 最小的嵌入到前面能够满足条件的娃娃中,
           再新用一个娃娃嵌套 h 倒数第二小的娃娃,
           那么这时嵌套了第二个娃娃的东西,一定能比已经嵌套了第个一的更能嵌套其它的娃娃 w 相同 ,而 h 更优【h大】
         
           比如说这堆娃娃有这样几个娃娃
           5
           30 400  (1)
           10 200  (1)
           10 300  (2) w 相同,必然重新嵌入不同的娃娃
           9 250   (2)
           8 250   (3)
           那么最优的结果就是 3,
           第一个娃娃嵌套第二个;
           第三个娃娃嵌套第四个;
           第五个娃娃单独嵌套。


           但是如果你按照 w 相同时 h 从大到小排序就是这样
           5
           30 400  (1)
           10 300  (1)
           10 200  (2)
           9 250   (3)
           8 250   (4)
           一样的数据, 答案是 4

code:

/*****************************************************************************************

E	Accepted	540 KB	343 ms	C++	1172 B	2013-08-04 21:16:03

题意:给你 N 个娃娃, 每个娃娃有特定的 w 和 h
      当且仅当 d1.w < d2.w && d1.h < d2.h , d1 才可以放入 d2中
      问:最少还可以剩下几个娃娃
算法:应该是要用 dp 做了,这里用贪心Orz
思路:感觉类似于导弹拦截系统
      先对娃娃们排序:先按照 w 从大到小排序, w 相同,则按照 h 从小到大排序
关于排序:先按照 w 从大到小排序可以理解吧【把小的嵌套到大的当中去】
           对于 w 相同时 h 从小到大排序
           如果 m 个 w 相同, 那么必然是嵌套在 m 个不同的娃娃中
           【可能是比它大的,也可能是它本身】
           先选择 h 最小的嵌入到前面能够满足条件的娃娃中,
           再新用一个娃娃嵌套 h 倒数第二小的娃娃,
           那么这时嵌套了第二个娃娃的东西,一定能比已经嵌套了第个一的更能嵌套其它的娃娃 w 相同 ,而 h 更优【h大】
           比如说这堆娃娃有这样几个娃娃
           5
           30 400  (1)
           10 200  (1)
           10 300  (2) w 相同,必然重新嵌入不同的娃娃
           9 250   (2)
           8 250   (3)
           那么最优的结果就是 3,
           第一个娃娃嵌套第二个;
           第三个娃娃嵌套第四个;
           第五个娃娃单独嵌套。

           但是如果你按照 w 相同时 h 从大到小排序就是这样
           5
           30 400  (1)
           10 300  (1)
           10 200  (2)
           9 250   (3)
           8 250   (4)
           一样的数据, 答案是 4

*****************************************************************************************/
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;

const int maxn = 20000+10;
const int INF = 10000+10;

struct Node
{
    int w,h;
}node[maxn], dp[maxn];

bool cmp(Node a, Node b)
{
    if(a.w == b.w) return a.h < b.h;
    else return a.w > b.w;
}

int main()
{
    int T;
    int n;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d", &n);
        for(int i = 0; i < n; i++)
        {
            scanf("%d%d", &node[i].w, &node[i].h);
            dp[i].w = dp[i].h = INF; //假设初始化有 N 个可以嵌套的娃娃
        }
        sort(node, node+n, cmp);
//for(int i = 0; i < n; i++) printf("%d %d\n", node[i].w, node[i].h); printf("\n");

        for(int i = 0; i < n; i++)
        {
            int j = 0;
            while(dp[j].w <= node[i].w || dp[j].h <= node[i].h) j++;
            dp[j].w = node[i].w; //不断更新为当前情况
            dp[j].h = node[i].h;
        }

// for(int i = 0; i < n; i++) printf("%d %d\n", dp[i].w, dp[i].h); printf("\n");

        int ans = 0;
        for(int i = 0; i < n; i++)
            if(dp[i].h != INF) //看有几个嵌套过
                ans++;

        printf("%d\n", ans);
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值