HDU 1677 Nested Dolls (贪心)

Nested Dolls

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3495    Accepted Submission(s): 1051

Problem Description
Dilworth is the world’s most prominent collector of Russian nested dolls: he literally has thousands of them! You know, the wooden hollow dolls of different sizes of which the smallest doll is contained in the second smallest, and this doll is in turn contained in the next one and so forth. One day he wonders if there is another way of nesting them so he will end up with fewer nested dolls? After all, that would make his collection even more magnificent! He unpacks each nested doll and measures the width and height of each contained doll. A doll with width w1 and height h1 will fit in another doll of width w2 and height h2 if and only if w1 < w2 and h1 < h2. Can you help him calculate the smallest number of nested dolls possible to assemble from his massive list of measurements?
 
Input
On the first line of input is a single positive integer 1 <= t <= 20 specifying the number of test cases to follow. Each test case begins with a positive integer 1 <= m <= 20000 on a line of itself telling the number of dolls in the test case. Next follow 2m positive integers w1, h1,w2, h2, . . . ,wm, hm, where wi is the width and hi is the height of doll number i. 1 <= wi, hi <= 10000 for all i.
 
Output
For each test case there should be one line of output containing the minimum number of nested dolls possible.
 
Sample Input
  
  
4 3 20 30 40 50 30 40 4 20 30 10 10 30 20 40 50 3 10 30 20 20 30 10 4 10 10 20 30 40 50 39 51
 
Sample Output
  
  
1 2 3 2
 
Source


题解:

给出m个娃娃,然后如果一个的w和h都大于另一个即可将其套进去,求最少能套成多少组。

这题就是贪心,先升序排w,然后降序排h,遍历m个娃娃,开个team数组存组数,如果没有符合可以套的,就存进去,如果找到第一个可以套的,那么就更新那个组的w和h的值。


AC代码:702MS。。。。。
#include<stdio.h>
#include<algorithm>
#include<iostream>
using namespace std;
struct doll
{
	int w,h;
};
bool cmp(struct doll a,struct doll b)
{
	if(a.w!=b.w) return a.w<b.w; //升序 w
	else return a.h>b.h; //降序 h 
}
int main()
{
	int t;
	doll p[20005],team[20005];
    scanf("%d",&t);
	while(t--)
	{
		int n; scanf("%d",&n);
		for(int i=0;i<n;i++)
		{
			scanf("%d %d",&p[i].w,&p[i].h);
		}
		sort(p,p+n,cmp);
		int count=0;
		
		for(int i=0;i<n;i++)  
        {  
            int flag=0;  
            
            for(int j=0;j<count;j++)  
            {  
                if(p[i].w>team[j].w && p[i].h>team[j].h)  
                {  
                    team[j]=p[i];  
                    flag=1;  
                    break;  
                }  
            }  
            
            if(flag==0) 
			{
				team[count++]=p[i];
				//printf("%d\n",p[i]);
			}
        }  
        printf("%d\n",count);  
	}
	return 0;
}


  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值