HDU 1677 Nested Dolls

Problem Description
Dilworth is the world’s most prominent collector of Russian nested dolls: he literally has thousands of them! You know, the wooden hollow dolls of different sizes of which the smallest doll is contained in the second smallest, and this doll is in turn contained in the next one and so forth. One day he wonders if there is another way of nesting them so he will end up with fewer nested dolls? After all, that would make his collection even more magnificent! He unpacks each nested doll and measures the width and height of each contained doll. A doll with width w1 and height h1 will fit in another doll of width w2 and height h2 if and only if w1 < w2 and h1 < h2. Can you help him calculate the smallest number of nested dolls possible to assemble from his massive list of measurements?
Input
On the first line of input is a single positive integer 1 <= t <= 20 specifying the number of test cases to follow. Each test case begins with a positive integer 1 <= m <= 20000 on a line of itself telling the number of dolls in the test case. Next follow 2m positive integers w1, h1,w2, h2, . . . ,wm, hm, where wi is the width and hi is the height of doll number i. 1 <= wi, hi <= 10000 for all i.
Output
For each test case there should be one line of output containing the minimum number of nested dolls possible.
Sample Input
4
3
20 30 40 50 30 40
4
20 30 10 10 30 20 40 50
3
10 30 20 20 30 10
4
10 10 20 30 40 50 39 51
Sample Output
1
2
3
2
分析:最长单调子序列变形。
code:
View Code
#include<stdio.h>
#include<stdlib.h>
struct node
{
int w,h;
}q[20001];
int cmp(const void*p1,const void*p2)
{
struct node*c=(struct node*)p1;
struct node*d=(struct node*)p2;
if((c->w)!=(d->w))
return c->w-d->w;
return d->h-c->h;
}
int main()
{
int tot,t,i,n,l,r,mid;
int d[20001];
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(i=0;i<n;i++)
scanf("%d%d",&q[i].w,&q[i].h);
qsort(q,n,sizeof(q[0]),cmp);
tot=0;
for(i=0;i<n;i++)
{
l=0;r=tot;
while(l<r)
{
mid=(l+r)>>1;
if(d[mid]>=q[i].h)
l=mid+1;
else r=mid;
}
d[l]=q[i].h;
if(l==tot)
tot++;
}
printf("%d\n",tot);

}
return 0;
}

转载于:https://www.cnblogs.com/dream-wind/archive/2012/03/16/2400627.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值