PAT 1017. Queueing at Bank (25)

1017. Queueing at Bank (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=10000) - the total number of customers, and K (<=100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:
7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10
Sample Output:
8.2

这道题依旧是个排队问题,运用到map 和multiset 隐含排序这个要点,就能很容易的完成这道题。一开始最后一个点始终过不了,后来发现理解错了题目意思,如果有用户在17:00以前到了银行,那么即使银行的空窗期在17:00以后,银行也要为这个客户提供服务

代码如下:

#include <iostream>
#include <set>
#include <map>
#include <algorithm>
#include <iomanip>
using namespace std;
#define OPEN 28800
#define CLOSE 61200
int main(int argc, char** argv) {
	int N,K;
	cin>>N>>K;
	map<int,int> customer;
	multiset<int> window;
	int i=N,hour,minute,second,last,time;
	while(i--)
	{
		cin>>hour;
		getchar();
		cin>>minute;
		getchar();
		cin>>second>>last;
		time=hour*3600+minute*60+second;
		if(last>60)
			last=60;
		customer[time]=last*60;
	}
	for(i=0;i<K;i++)
		window.insert(OPEN); //initial the windows
	map<int,int>::iterator mIt;
	multiset<int>::iterator sIt;
	int waitTime,totalTime=0,count=0;
	float aveTime;
	for(mIt=customer.begin();mIt!=customer.end();mIt++)
	{
		sIt=window.begin();
		if(mIt->first>CLOSE)
			break;
		waitTime=*sIt-mIt->first;
		if(waitTime>0)
			totalTime+=waitTime;
		last=max(*sIt,mIt->first)+mIt->second;
		window.insert(last);
		window.erase(sIt);
		if(window.empty())
			break;
		count++;
	}
	aveTime=(totalTime*1.0)/count;
	aveTime/=60;
	cout<<fixed<<setprecision(1)<<aveTime<<endl;;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值