PAT 1077. Kuchiguse (20)

1077. Kuchiguse (20)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
HOU, Qiming

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker's personality. Such a preference is called "Kuchiguse" and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle "nyan~" is often used as a stereotype for characters with a cat-like personality:

  • Itai nyan~ (It hurts, nyan~)
  • Ninjin wa iyada nyan~ (I hate carrots, nyan~)

    Now given a few lines spoken by the same character, can you find her Kuchiguse?

    Input Specification:

    Each input file contains one test case. For each case, the first line is an integer N (2<=N<=100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character's spoken line. The spoken lines are case sensitive.

    Output Specification:

    For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write "nai".

    Sample Input 1:
    3
    Itai nyan~
    Ninjin wa iyadanyan~
    uhhh nyan~
    
    Sample Output 1:
    nyan~
    
    Sample Input 2:
    3
    Itai!
    Ninjinnwaiyada T_T
    T_T
    
    Sample Output 2:
    nai
    

这道题是求LCS,不过这道题只要求求后缀,因此就简单了。代码如下:

#include <iostream>
#include <algorithm>
#include <vector>
#include <string>
#include <iomanip>
#include <cstring>
using namespace std;
int main(void)
{
	int i,N;
	cin>>N;
	vector<string> raw;
	getchar();
	for(i=0;i<N;i++)
	{
		string temp;
		getline(cin,temp);
		reverse(temp.begin(),temp.end());
		raw.push_back(temp);
	}
	string nyan=""; //nyan~
	for(int j=0;j<raw[0].size()&&j<raw[1].size();j++)
		if(raw[0][j]==raw[1][j])
			nyan+=raw[0][j];
		else
			break;
	if(nyan.size()==0)
	{
		cout<<"nai";
		return 0;
	}
	for(i=2;i<N;i++)
	{
		int j;
		for(j=0;j<raw[i].size()&&j<nyan.size();j++)
			if(raw[i][j]!=nyan[j])
				break;
		if(j==0)
		{
			cout<<"nai";
			return 0;
		}
		else
			nyan=raw[i].substr(0,j);
	}
	reverse(nyan.begin(),nyan.end());
	cout<<nyan;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值