PAT - 甲级 - 1077. Kuchiguse (20)(字符串处理)

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker's personality. Such a preference is called "Kuchiguse" and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle "nyan~" is often used as a stereotype for characters with a cat-like personality:

  • Itai nyan~ (It hurts, nyan~)
  • Ninjin wa iyada nyan~ (I hate carrots, nyan~)

    Now given a few lines spoken by the same character, can you find her Kuchiguse?

    Input Specification:

    Each input file contains one test case. For each case, the first line is an integer N (2<=N<=100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character's spoken line. The spoken lines are case sensitive.

    Output Specification:

    For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write "nai".

    Sample Input 1:
    3
    Itai nyan~
    Ninjin wa iyadanyan~
    uhhh nyan~
    
    Sample Output 1:
    nyan~
    
    Sample Input 2:
    3
    Itai!
    Ninjinnwaiyada T_T
    T_T
    
    Sample Output 2:
    nai

给定条件:
1.给定n句话

要求:
1.求出这些话的最长相同后缀

求解:
1.首先将所有字符串反转,方便比较
2.以第一句话为基准,分别用其他话来比较
3.只要有一句不相同,则跳出比较,从0位置到当前位置前一位就是最长的相同后缀(可能为0)


#include <cstdio>
#include <algorithm>
#include <vector>
#include <iostream>
#define min(a,b) (a) > (b)?(b):(a)
using namespace std;

int n, len = 9999999;
string s[105];
vector<char> v;
int main() {
	scanf("%d", &n);
	getchar();
	for(int i = 0; i < n; i++) {
		getline(cin, s[i]);
		reverse(s[i].begin(), s[i].end());
		len = min(len, s[i].length());
	}

	for(int i = 0; i < len; i++) {
		int flag = 1;
		char temp = s[0][i];
		for(int j = 1; j < n; j++) {
			if(s[j][i] != temp) {
				flag = 0;
				break;
			}
		}
		if(flag == 1) {
			v.push_back(temp);
		} else {
			break;
		}
	}
	if(v.size() == 0) {
		printf("nai\n");
	} else {
		for(int i = v.size()-1; i >= 0; i--) {
			printf("%c", v[i]);
		}
		printf("\n");
	}

	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值