hdu 5742 chess SG函数

Chess

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1908    Accepted Submission(s): 831


Problem Description
Alice and Bob are playing a special chess game on an n × 20 chessboard. There are several chesses on the chessboard. They can move one chess in one turn. If there are no other chesses on the right adjacent block of the moved chess, move the chess to its right adjacent block. Otherwise, skip over these chesses and move to the right adjacent block of them. Two chesses can’t be placed at one block and no chess can be placed out of the chessboard. When someone can’t move any chess during his/her turn, he/she will lose the game. Alice always take the first turn. Both Alice and Bob will play the game with the best strategy. Alice wants to know if she can win the game.
 

Input
Multiple test cases.

The first line contains an integer  T(T100) , indicates the number of test cases.

For each test case, the first line contains a single integer  n(n1000) , the number of lines of chessboard.

Then  n  lines, the first integer of ith line is  m(m20) , indicates the number of chesses on the ith line of the chessboard. Then m integers  pj(1pj20) followed, the position of each chess.
 

Output
For each test case, output one line of “YES” if Alice can win the game, “NO” otherwise.
 

Sample Input
  
  
2 1 2 19 20 2 1 19 1 18
 

Sample Output
  
  
NO YES


题意:给n堆石子,有两种操作,第一种是选择任意一堆取走一些石子,可以取完这一堆,但不能不取。第二种操作是把某一堆分成三堆石子,每堆石子不能为空。问先手是否必胜。


SG函数,因为数据是1e9,所以打表找一下规律。

#include <bits/stdc++.h>

using namespace std;

int SG[1000];
int sg(int x)
{
    if(SG[x] != -1) return SG[x];
    int vis[150] = {0};
    for(int i = 1;i <= x;i++)     ///正常的nim取石子
        vis[sg(x-i)] = 1;
    for(int i = 1;i <= 100;i++){  ///采用另一种操作,分成三堆
        for(int j = 1;j <= 100;j++){
            for(int k = 1;k <= 100;k++){
                if(i+j+k == x){
                    vis[sg(i)^sg(j)^sg(k)] = 1;
                }
            }
        }
    }
    for(int i = 0;;i++)
        if(!vis[i]) return SG[x] = i;
}

void Init()
{
    memset(SG,-1,sizeof SG);
    SG[0] = 0;
    SG[1] = 1;
    SG[2] = 2;
    sg(100);
    for(int i = 0;i <= 100;i++) printf("%d %d\n",i,SG[i]);
}

int SG_(int x)
{
    if(x%8 == 7) return x+1;
    if(x%8 == 0) return x-1;
    return x;
}

int main()
{
    //Init();  打表找规律
    int T;
    scanf("%d",&T);
    while(T--){
        int n;
        scanf("%d",&n);
        int ans = 0;
        for(int i = 1;i <= n;i++){
            int t;
            scanf("%d",&t);
            ans ^= SG_(t);
        }
        if(ans) puts("First player wins.");
        else    puts("Second player wins.");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 适合毕业设计、课程设计作业。这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。 所有源码均经过严格测试,可以直接运行,可以放心下载使用。有任何使用问题欢迎随时与博主沟通,第一时间进行解答!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值