HDU 5724 Chess(sg函数)

Chess
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3721 Accepted Submission(s): 1519

Problem Description
Alice and Bob are playing a special chess game on an n × 20 chessboard. There are several chesses on the chessboard. They can move one chess in one turn. If there are no other chesses on the right adjacent block of the moved chess, move the chess to its right adjacent block. Otherwise, skip over these chesses and move to the right adjacent block of them. Two chesses can’t be placed at one block and no chess can be placed out of the chessboard. When someone can’t move any chess during his/her turn, he/she will lose the game. Alice always take the first turn. Both Alice and Bob will play the game with the best strategy. Alice wants to know if she can win the game.

Input
Multiple test cases.

The first line contains an integer T(T≤100), indicates the number of test cases.

For each test case, the first line contains a single integer n(n≤1000), the number of lines of chessboard.

Then n lines, the first integer of ith line is m(m≤20), indicates the number of chesses on the ith line of the chessboard. Then m integers pj(1≤pj≤20) followed, the position of each chess.

Output
For each test case, output one line of “YES” if Alice can win the game, “NO” otherwise.

Sample Input
2
1
2 19 20
2
1 19
1 18

Sample Output
NO
YES

题意

Alice和Bob一起下棋,这里有一个 n x 20 nx20 nx20的棋盘即有n行20列,对于每一列会有m个棋子,并告诉你棋子所在的列数,每一轮他们可以选择任意一行的莫一个棋子将他往后移动到最靠近他的空位置上,若谁不能移动了则败

思路

由于只有20列所以一共只有 2 2 0 2^20 220总状态,我们可以将棋子所在的位置转化为二进制下的1,0表示为空位置,我们可以用sg函数处理出 1 &lt; &lt; 20 1&lt;&lt;20 1<<20个状态的sg值,对于每一个输入的n我们可以枚举他的下一个状态,然后使得sg函数中的vis[sg[]]=1即可,但是我们可以用位运算去遍历当前情况下的下一状态是什么
最后一行的sg值得异或若为0先手必败

#include<bits/stdc++.h>
using namespace std;
int vis[21];
int sg[1<<21];
int getSG(int n)
{
    memset(vis,0,sizeof(vis));
    for(int i=20; i>=0; i--)
        if(n&(1<<i))
        {
            for(int j=i-1; j>=0; j--)
                if(!(n&(1<<j)))
                {
                    //printf("%d %d\n",n&(1<<i),(1<<j));
                    vis[sg[(n^(1<<i))^(1<<j)]]=1;
                    break;
                }
        }
    for(int i=0; i<=20; i++)
    {
        if(vis[i]==0)
        {
            return i;
        }
    }
}
int main()
{
    for(int i=0; i<(1<<20); i++)
        sg[i]=getSG(i);
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        int ans=0;
        while(n--)
        {
            int m;
            scanf("%d",&m);
            int sum=0;
            for(int i=0; i<m; i++)
            {
                int x;
                scanf("%d",&x);
                sum+=1<<(20-x);
            }
            ans^=sg[sum];
        }
        if(ans==0)
            printf("NO\n");
        else
            printf("YES\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值