POJ 2411 Mondriaan's Dream (状态压缩dp)

126 篇文章 2 订阅
46 篇文章 0 订阅

题意很简单就是给你n*m的矩阵然后让你看看用2*1的小矩阵填满有多少种方法。

标准的状压啊,需要注意的是连续的点有两种情况就是可以横放,也可以竖放。

discuss里面有一个25行的代码说的很好。

用2进制的01表示不放还是放
第i行只和i-1行有关
枚举i-1行的每个状态,推出由此状态能达到的i行状态
如果i-1行的出发状态某处未放,必然要在i行放一个竖的方块,所以我对上一行状态按位取反之后的状态就是放置了竖方块的状态。
然后用搜索扫一道在i行放横着的方块的所有可能,并且把这些状态累加上i-1的出发状态的方法数,如果该方法数为0,直接continue。
举个例子
2 4
1111
1111
状态可以由
1100   0000   0110    0011   1111
0000   0000   0000    0000   0000
这五种i-1的状态达到,故2 4 的答案为5

Mondriaan's Dream
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 11159 Accepted: 6490

Description

Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his 'toilet series' (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways. 

Expert as he was in this material, he saw at a glance that he'll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won't turn into a nightmare!

Input

The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.

Output

For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.

Sample Input

1 2
1 3
1 4
2 2
2 3
2 4
2 11
4 11
0 0

Sample Output

1
0
1
2
3
5
144
51205
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-4
#define M 1000100
///#define LL __int64
#define LL long long
#define INF 0x7ffffff
#define PI 3.1415926535898

using namespace std;

const int maxn = 4010;

LL dp[15][1<<13];
int n, m;
LL cnt;

void dfs(int i, int pos, int j)
{
    if(pos == m)
    {
        dp[i][j] += cnt;
        return;
    }
    dfs(i, pos+1, j);
    if(pos <= m-2 && !(j&(1<<pos)) && !(j&(1<<(pos+1))))
        dfs(i, pos+2, j|(1<<pos)|1<<(pos+1));
}

int main()
{
    while(cin >>n>>m)
    {
        if(!n && !m)
            break;
        if((n*m)%2)
        {
            cout<<0<<endl;
            continue;
        }
        memset(dp, 0, sizeof(dp));
        cnt = 1;
        dfs(1, 0, 0);
        for(int i = 2; i <= n; i++)
        {
            for(int j = 0; j <= ((1<<m)-1); j++)
            {
                if(dp[i-1][j])
                    cnt = dp[i-1][j];
                else
                    continue;
                dfs(i, 0, ~j&((1<<m)-1));
            }
        }
        cout<<dp[n][(1<<m)-1]<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值