POJ-3122 Pie 解题报告(二分) 平分派饼

链接- J - Pie

Time Limit:1000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u
 
Description
My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:
  • One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
  • One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10−3.

Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327
3.1416
50.2655

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).
 

题目大意:有N个饼平分给F+1个人,求每人能分到的最大面积(饼可以切分不能合,每块切后剩下的扔掉。。。好浪费~~~)。

#include<stdio.h>
int N,F,r,n;
double s[10000+5];
#define pi 3.141592653589793238462643383279502884197169399
#define esp 1e-6
int main()
{	
	scanf("%d",&n);
		while(n--)
		{	
			int i;
			double smax=0;
			scanf("%d%d",&N,&F);
			for(i=0;i<N;i++)
			{	scanf("%d",&r);
				s[i]=r*r*pi;
				if(s[i]>smax) smax=s[i];
			}
			double l=0,r=smax,mid;
			while(r-l>esp)
			{
				mid=l+(r-l)/2;
				int cur=0;
				for(i=0;i<N;i++)
				{
					cur=cur+int(s[i]/mid);
				}
				if(cur>=F+1)
					l=mid;
				else
					r=mid;	
			}
			printf("%.4lf\n",l);
		}

	return 0;
}


代码解析:二分思路,就是在一个区间内二分快速查找到一个固定的值,可能我们之前不知道它的具体值,但是能确定在某个精度范围内是一定能找到它的,它也就是答案了。。。

这个题目,不断取面积值,设先取S0,可得每块饼最多能切出几个S0,将总和与人数F+1比较,如果符合则继续二分,直到满足精度则退出循环。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值