AndroidStudio,IDE常见错误AndroidStudio(Error:(1, 0) Minimum supported Gradle version is 3.3. Current ver

原创 2017年05月23日 12:03:24

1.问题复现
项目之前使用的As版本是2.2版本,升级了As到2.3版本后就会出现这个问题
2.原理
As2.2的Gradle版本和As版本一致,而Gradle插件版本为2.14.1,As2.3对应的Gradle插件版本 为3.3
3.解决办法
先查看wrapper.properties下的Gradle插件版本,需要插件版本与Gradle版本一致
有两种形式,升级Gradle插件版本或降低Gradle版本,当然选择升级
第一步:禁用Instant Run,在Settings/Preferneces > Build, Execution, Deployment option > Instant Run 中,取消所有的选中项
第二步:设置wrapper.properties下distributionUrl=https://services.gradle.org/distributions/gradle-3.3-all.zip,开始自动下载或手动下载
第三步:删除project下的build文件夹,Clean项目重新编译,问题解决

版权声明:本文为博主原创文章,未经博主允许不得转载。

解决Error:(1, 0) Minimum supported Gradle version is 3.3. Current version is 2.14.1.

报错如下图 只需要改一个地方即可 改成3.3之前你确定有这个版本,查看有没有这个版本看如下图的一般对应的gradle版本如下...
  • zxzmola
  • zxzmola
  • 2017年03月03日 09:01
  • 892

Error:Minimum supported Gradle version is 2.14.1. Current version is 2.10.原因分析和解决。

最近和主管一起开发项目一直出现这个问题: Error:Minimum supported Gradle version is 2.14.1. Current version is 12.10. If ...
  • wanglaohushiwo
  • wanglaohushiwo
  • 2016年11月30日 21:36
  • 6715

解决Error:(16, 0) Minimum supported Gradle version is 3.3. Current version is 2.14.1

最近gradle更新到了3.3,studio 每次重新进入项目都会提醒更新,于是手贱便点击了update。结果就是自己挖的坑把自己埋了一天半,在这记录一下,以便各位道友谨慎小心。点击更新后发现我的项目...
  • codekxx
  • codekxx
  • 2017年04月27日 15:20
  • 5882

android studio 一次编译错误:Error:Minimum supported Gradle version is 2.14.1.

因为需要,今天从git上重新下载工程到另一个目录下,结果运行的时候报了这个错:Error:Minimum supported Gradle version is 2.14.1.  Current ve...
  • Android_Amelia
  • Android_Amelia
  • 2016年09月13日 15:18
  • 19355

Error:(1, 0) Minimum supported Gradle version is 3.3. Current version is 2.14.1.

使用Android studio 时,有时候使用第三方,导致这个错误,其实就是Gradle 版本不一致导致的,studio又不会自动下载,只有我们开发人员去官网下载,解压到文件中去就行了  ...
  • qq_36255612
  • qq_36255612
  • 2017年06月09日 13:00
  • 687

Error:This Gradle plugin requires Studio 3.0 minimum解决办法

问题: Error:This Gradle plugin requires Studio 3.0 minimum 解决办法: 在gradle.properties中加入以下这句: gradle.pro...
  • VonSdite
  • VonSdite
  • 2017年11月14日 15:45
  • 706

Error:This Gradle plugin requires Studio 3.0 minimum

今天遇到了一个Error:This Gradle plugin requires Studio 3.0 minimum这样的问题,我觉得是我的studio的版本不够高,我的studio是2.3.3版本...
  • shenggaofei
  • shenggaofei
  • 2017年10月06日 16:47
  • 8099

解决bug:AndroidStudio导项目出异常Minimum supported Gradle version is 3.3.Current version is 2.14

Bug: Minimum supported Gradle version is 3.3. Current version is 2.14.1. 将/gradle-wrapper.properties...
  • Sun_2134
  • Sun_2134
  • 2017年07月25日 17:57
  • 1670

Android中导入他人项目时报错:Error:(1, 0) Minimum supported Gradle version is 3.3. Current version is 2.14.1...

编写不易,如有转载,请声明出处: 梦回河口: 报错的全称为:Error:(1, 0) Minimum supported Gradle version is 3.3. Current version ...
  • zxc514257857
  • zxc514257857
  • 2017年06月07日 17:49
  • 817

AndroidStudio创建minimumSDK4.1以下版本后没有R文件已解决

将该module的  build.gradle中  minSdkVersion 7 targetSdkVersion 23 分别改为7和14 然后点Build中的Clean Proje...
  • sdjianfei
  • sdjianfei
  • 2016年02月01日 20:16
  • 750
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:AndroidStudio,IDE常见错误AndroidStudio(Error:(1, 0) Minimum supported Gradle version is 3.3. Current ver
举报原因:
原因补充:

(最多只允许输入30个字)