Error:Gradle version xx is required. Current version is xx.

标签: gradle android studio android
2427人阅读 评论(1) 收藏 举报
分类:

Android Studio更新到2.0之后默认下载的Gradle为2.10,如果你的项目用到的Gradle版本与现有的Gradle版本不匹配那么就会报“Error:Gradle version xx is required. Current version is xx. If using the gradle wrapper, try editing the distributionUrl…”错误。 如图:
Error:Gradle version xx is required
下面就跟大家分享一种简单的解决办法:
1. 前往http://services.gradle.org/distributions下载对应版本的Gradle。提示:下载以xxbin.zip结尾的文件即可。
2. 将下载的文件解压到/Applications/Android Studio.app/Contents/gradle目录下。 如图:
gradle安装位置
3. 然后修改Android Studio的”Gradle home:”的路径即可。如图:
修改Gradle home路径

查看评论

Gradle version 1.10 is required. Current version is 2.2.1 :此类问题的一次性解决方案(已验证)

错误提示: 解决方案: 1. 首先确保你打开工程的方法是正确的,一般说来,Android Studio中 打开从GitHub上下载的第三方库项目时,应该当按如下步骤: 2.下一步会让你选择使...
  • lamelias
  • lamelias
  • 2015-04-15 11:50:04
  • 7612

**Gradle version 2.2 is required. Current version is 2.14.1.问题解决方法**

Gradle version 2.2 is required. Current version is 2.14.1.问题解决方法今天使用Android studio 导入项目文件时发现出错: Erro...
  • xiaopihaiergu
  • xiaopihaiergu
  • 2017-03-18 21:12:27
  • 457

Android gradle plugin和 Gradle版本关系\Gradle version 1.10 is required. Current version is 2.0

http://ask.android-studio.org/?/question/311问题:Gradle version 1.10 is required. Current version is 2...
  • xx326664162
  • xx326664162
  • 2016-04-07 17:42:51
  • 13478

Android开发出现Warning:Gradle version 2.10 is required. Current version is 2.8. If u

Warning:Gradle version 2.10 is required. Current version is 2.8. If using the gradle wrapper, try ed...
  • oQiHaoGongYuan
  • oQiHaoGongYuan
  • 2016-01-15 20:59:47
  • 15466

解决Gradle版本不匹配

Gradle version XXX is required. Current version is XXX If using the gradle wrapper, try editing the ...
  • hehongdan
  • hehongdan
  • 2016-07-16 20:02:36
  • 6165

导入错误,Gradle version 2.10 is required. Current version is 2.8

今天导入一个AS项目,结果提示: Error:Gradle version 2.10 is required. Current version is 2.8. If using the gradle...
  • gd5544
  • gd5544
  • 2016-05-30 23:01:06
  • 1852

自定义TextView,解决文字排版,对Html格式的文字无效

最近在做着一个项目,里边会显示很长的一段文字,但是这些文字并不会整齐地排列,遇到文字中带有中英文时,果断给我换行了,好无语..接着就是不断地百度百度,找到了一堆一两年前的东西,不是叫你半角转全角,就是...
  • bsddcxn
  • bsddcxn
  • 2015-11-10 14:31:17
  • 329

Error:(1, 0) Gradle version 2.2 is required. Current version is 3.4.1.

我们在使用Android Studio的时候新建项目没什么问题的,但是当我们下载一份Github上的项目导入进去的时候却没法正常使用,其原因主要是gradle配置问题。而由于gradle这个玩意儿版本...
  • qq_15003505
  • qq_15003505
  • 2017-04-01 16:40:44
  • 4331

android studio 的一个问题Error:Gradle version 2.2 is required. Current version is 2.14.1. If using the gr

已经开始用android staudio 一段时间了, 总是有这个那个的问题,谁叫咱们在ch呢, 今天遇到一个问题 Error:Gradle version 2.2 is required. Cur...
  • sinat_26761191
  • sinat_26761191
  • 2017-03-01 17:22:19
  • 2039

Gradle version 2.2 is required. Current version is 2.1. If using the gradle wrapper, try editing the

gradle version 2.2 is required
  • qq_28261207
  • qq_28261207
  • 2016-08-25 10:50:48
  • 371
    个人资料
    专栏达人 持之以恒
    等级:
    访问量: 107万+
    积分: 1万+
    排名: 1387
    你需要的,才是干货@开源项目
    博客专栏
    最新评论