POJ1248/HDOJ1015——Safecracker

水题就要任性地用很水的方法来解~

大体题意:给定一个target、一个由大写字母组成的字符串,从中任选5个,设为v,w,x,y,z,求满足v-w^2+x^3-y^4+z^5=target的5个字符,可能多解,输出字典序最大解,无解输出“no solution”

Problem Description:

=== Op tech briefing, 2002/11/02 06:42 CST ==="The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein's secrets and wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters, usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, ..., Z=26). The combination is then vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary."v - w^2 + x^3 - y^4 + z^5 = target quot;For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn't exist then."

=== Op tech directive, computer division, 2002/11/02 12:30 CST === "Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations. Input consists of one or more lines containing a positive integer target less than twelve million, a space, then at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input. For each line output the Klein combination, break ties with lexicographic order, or 'no solution' if there is no correct combination. Use the exact format shown below." 

        Sample Input

1 ABCDEFGHIJKL

11700519 ZAYEXIWOVU

3072997 SOUGHT

1234567 THEQUICKFROG

0 END

Sample Output

LKEBA

YOXUZ

GHOST

no solution 

 

 

 

A的码:

#include<iostream>
#include<cstring>
#include<algorithm>
#define cti(c) c-'A'    //char to int 

using namespace std;

//君莫笑~
//这个表是另用程序跑出来打印在txt里复制过来的结果
//其实直接把v - w^2 + x^3 - y^4 + z^5放到循环里照样A,无奈经验少,在这做傻事
int a[26][5]={	{1,1,1,1,1},
				{2,4,8,16,32},
				{3,9,27,81,243},
				{4,16,64,256,1024},
				{5,25,125,625,3125},
				{6,36,216,1296,7776},
				{7,49,343,2401,16807},
				{8,64,512,4096,32768},
				{9,81,729,6561,59049},
				{10,100,1000,10000,100000},
				{11,121,1331,14641,161051},
				{12,144,1728,20736,248832},
				{13,169,2197,28561,371293},
				{14,196,2744,38416,537824},
				{15,225,3375,50625,759375},
				{16,256,4096,65536,1048576},
				{17,289,4913,83521,1419857},
				{18,324,5832,104976,1889568},
				{19,361,6859,130321,2476099},
				{20,400,8000,160000,3200000},
				{21,441,9261,194481,4084101},
				{22,484,10648,234256,5153632},
				{23,529,12167,279841,6436343},
				{24,576,13824,331776,7962624},
				{25,625,15625,390625,9765625},
				{26,676,17576,456976,11881376},	};

int main()
{
	int t,i,j,k,l,m,sum,w;
	char u[30],s[6];   //u输入的字符串  s存放结果
	s[5]=0;
	
    while(cin>>t>>u&&(t!=0||strcmp(u,"END")!=0))
	{
        int f = 0;   //判断无解标志
        w=strlen(u);
        sort(u,u+w);  //对字符串排序,方便取字典序最大解
        w--;
        for(i=w;i>=0;i--)   //暴力循环,还好数据量小
		{
            for(j=w;j>=0;j--)  //每重循环都是对字符串从后向前取字符来找最大解
			{
                for(k=w;k>=0;k--)
				{
                    for(l=w;l>=0;l--)
					{
                        for(m=w;m>=0;m--)
						{
                            if(i!=j&&i!=k&&i!=l&&i!=m&&j!=k&&j!=l&&j!=m&&k!=l&&k!=m&&l!=m) //去重 
							{
								//sum=v - w^2 + x^3 - y^4 + z^5
                                sum=a[cti(u[i])][0]-a[cti(u[j])][1]+a[cti(u[k])][2]-a[cti(u[l])][3]+a[cti(u[m])][4];
                                if(sum==t)
								{
                                    f=1;
                                    s[0]=u[i];
                                    s[1]=u[j];
                                    s[2]=u[k];
                                    s[3]=u[l];
                                    s[4]=u[m];
                                    cout<<s<<endl;
                                    goto END; 
                                }
                            }
                        }
                    }
                }
            }
        }
        END:;
        if(!f)
			cout<<"no solution"<<endl;
    }
    return 0;
}

 

 

 




 

Python网络爬虫与推荐算法新闻推荐平台:网络爬虫:通过Python实现新浪新闻的爬取,可爬取新闻页面上的标题、文本、图片、视频链接(保留排版) 推荐算法:权重衰减+标签推荐+区域推荐+热点推荐.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值