1004 Median(2011年浙江大学计算机及软件工程研究生机试真题)

题目描述:

    Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17} is 15. The median of two sequences is defined to be the median of the non-decreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.
    Given two increasing sequences of integers, you are asked to find their median.

输入:

    Each input file may contain more than one test case.
    Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤1000000) is the size of that sequence. Then N integers follow, separated by a space.
    It is guaranteed that all the integers are in the range of long int.

输出:

    For each test case you should output the median of the two given sequences in a line.

样例输入:
4 11 12 13 14
5 9 10 15 16 17
样例输出:
13

代码如下:

//1004 Median
#include<iostream>
#include<stdio.h>
using namespace std;
long a[1000010];
long b[1000010];
long c[2000010];
const  long inf=0xffff;//设置最大数 
int main()
{
	long N,M,i,j,k;
	char ch;
	while(cin>>N)
	{
		    j=k=0;
			
			for(i=0;i<N;i++)
			scanf("%d",&a[i]);
			a[i]=inf;//设置临界状态 
		    cin>>M;
		    for(i=0;i<M;i++)
		    scanf("%d",&b[i]);
		    b[i]=inf;//设置临界状态 
		    i=0;
		    while(i<M+N)
			{
				
					if(a[j]>b[k])
					{
						c[i++]=b[k++];
					}
					else
					{
						c[i++]=a[j++];
					}
			} 
			cout<<c[(M+N-1)/2]<<endl;
	}
	return 0;
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Sunshine_gao

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值