【HDU-1023】 Train Problem II 【卡特兰数+高精度】

传送门:http://acm.split.hdu.edu.cn/showproblem.php?pid=1023

描述:

Train Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8612    Accepted Submission(s): 4613


Problem Description
As we all know the Train Problem I, the boss of the Ignatius Train Station want to know if all the trains come in strict-increasing order, how many orders that all the trains can get out of the railway.
 

Input
The input contains several test cases. Each test cases consists of a number N(1<=N<=100). The input is terminated by the end of file.
 

Output
For each test case, you should output how many ways that all the trains can get out of the railway.
 

Sample Input
  
  
1 2 3 10
 

Sample Output
  
  
1 2 5 16796
Hint
The result will be very large, so you may not process it by 32-bit integers.
 

Author
Ignatius.L
 

Recommend
We have carefully selected several similar problems for you:   1133  1022  1130  1131  1134 

题意:
给你一个数n,表示有n辆火车,编号从1到n,从远方驶过来,问你有多少种出站的可能。

思路:

模拟栈的问题而已。

这道题其实也是组合数学卡特兰数的一个典型应用而已。

卡特兰数的介绍推荐看ACdreamer的http://blog.csdn.net/acdreamers/article/details/7628667

和kuangbin的 http://www.cnblogs.com/kuangbin/archive/2012/03/21/2410516.html  这两篇博客

当然100以内你也可以打表:

可以去戳这个网站,里面有1到100的卡特兰数 http://blog.csdn.net/lttree/article/details/29392541

代码一(C++):
#include <iostream>
#include <stdio.h>
using namespace std;

int a[101][101]={0};
int main(){
  int n,i,j,len,r,temp,t;
  int b[101];
  a[1][0] = 1;
  len = 1;
  b[1] = 1;
  for(i=2;i<=100;i++){
    t = i-1;
    for(j=0;j<len;j++) //乘法
      a[i][j] = a[i-1][j]*(4*t+2);
    for(r=j=0;j<len;j++) { //处理相乘结果
      temp = a[i][j] + r;
      a[i][j] = temp % 10;
      r = temp / 10;
    }
    while(r){ //进位处理
      a[i][len++] = r % 10;
      r /= 10;
    }

    for(j=len-1,r=0;j>=0;j--){ //除法
      temp = r*10 + a[i][j];
      a[i][j] = temp/(t+2);
      r = temp%(t+2);
    }
    while(!a[i][len-1]) //高位零处理
      len --;
      b[i] = len;
    }
    while(cin>>n){   
      for(j=b[n]-1;j>=0;j--)
        printf("%d",a[n][j]);
      puts("");
    }
  return 0;
}

代码二(java处理高精度):
import java.io.*;  
import java.util.*;  
import java.math.BigInteger;  
  
  
public class Main  
{  
    public static void main(String args[])  
    {         
        BigInteger[] a = new BigInteger[101];  
        a[0] = BigInteger.ZERO;  
        a[1] = BigInteger.valueOf(1);  
        for(int i = 2; i <= 100; ++i)  
            a[i] = a[i - 1].multiply(BigInteger.valueOf(4 * i - 2)).divide(BigInteger.valueOf(i+1));  
            Scanner in = new Scanner(System.in);  
            int n;  
            while(in.hasNext())  
            {  
                n = in.nextInt();  
                System.out.println(a[n]);  
            }  
    }  
} 




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值