1029. Median (25)

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17} is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (<=1000000) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output

For each test case you should output the median of the two given sequences in a line.

Sample Input
4 11 12 13 14
5 9 10 15 16 17
Sample Output
13

题目大意:

给定一个有N个整数的递增序列S,中位数是处于中间位置的数字。例如,S1={11, 12, 13, 14} 的中位数是12,S2={9, 10, 15, 16, 17}的中位数是15。两个序列的中位数被定义为非递减序列的中值,该序列包含了两个序列的所有元素。例如S1和S2的终止是13;
给定两个递增整数序列,要求你求出他们的中位数。
输入:
每个测试文件包含一个测试用例。每个测试用例占2行,每行都给出一个序列的信息。对于每个序列,第一个正整数N(<=100000)是该序列的大小。然后是N个正整数,被一个空格隔开。保证所有整数都在长整数范围内。
输出:
对于每个测试用例您应该将两个序列的中值输出到一行中。

代码:

#include<stdio.h>
#include<algorithm>
#include<vector>
using namespace std;
vector<long long> arr;
int main()
{
    int i,j,n,m,t;
    long long k;
    scanf("%d",&n);
    for(i=0;i<n;i++)
    {
        scanf("%lld",&k);
        arr.push_back(k);
    }
    scanf("%d",&m);
    for(i=0;i<m;i++)
    {
        scanf("%lld",&k);
        arr.push_back(k);
    }
    sort(arr.begin(),arr.end());
    k=arr[(arr.size()-1)/2];
    printf("%lld\n",k);
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值