1029 Median (25分)

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×105 ) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

 4 11 12 13 14 5 9 10 15 16 17

Sample Output:

13

思路:

找两个序列的中位数,坑点就是long 在大数据可能会超内存。

解题方法:

1.优先队列
第一个想到的,先复习一下优先队列:
构造:

less表示升序排序,内部用一个大顶堆实现
priority_queue<int,vector<int>,less<int> > p;//等同于priority_queue<int> p;
greater表示降序排序,内部用一个小顶堆实现
priority_queue<int,vector<int>,greater<int> > p;

操作:
无序容器(这里的无序指的是程序员不可见,不能随机存取)
常用到的就下面几个操作:

p.top();//获得堆顶元素
p.pop();//删除堆顶
p.push();//插入堆
p.empty();//判断是否为空

暴破:

#include <iostream>
#include <climits>
#include <queue>
using namespace std;
int main() {
    queue<int> a, b;
    int n, m, num, cnt = 0;
    scanf("%d", &n);
    for(int i = 0; i < n; i++) {
        scanf("%d", &num);
        a.push(num);
    }
    a.push(INT_MAX);
    scanf("%d", &m);
    for(int i = 0; i < m; i++) {
        scanf("%d", &num);
        b.push(num);
        if(cnt == (n + m - 1) / 2) {
            printf("%d", min(a.front(), b.front()));
            return 0;
        }
        if(a.front() < b.front())   
            a.pop();
        else                        
            b.pop();
        cnt++;
    }
    b.push(INT_MAX);
    for(; cnt < (n + m - 1) / 2; cnt++) {
        if(a.front() < b.front())    
            a.pop();
        else                         
            b.pop();
    }
    printf("%d", min(a.front(), b.front()));
    return 0;
}

效果不是很好的样子:
在这里插入图片描述
2.vector+快排?

#include<bits/stdc++.h>

using namespace std;
typedef long long ll;
vector<ll> temp;

int main() {
    for (int i = 0; i < 2; i++) {
        int n;
        cin >> n;
        for (int j = 0; j < n; j++) {
            ll t;
            scanf("%ld", &t);
            temp.push_back(t);
        }
    }
    int Index;
    if (temp.size() % 2 == 0)
        Index = temp.size() / 2 - 1;
    else
        Index = temp.size() / 2;

    sort(temp.begin(), temp.end());
    cout << temp[Index] << endl;
}

然并卵
在这里插入图片描述
3.强的人:
PAT甲级 1029 Median(25 分)AC 解决内存超限

总结:

太菜了,自愧不如

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值