1029 Median (25 分)-PAT甲级

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×105) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13

 题目大意:求两个序列按照数值递增顺序合并后的中间位置的元素值

思路:使用双指针按照序列数值递增顺序归并两个序列为一个序列,假设归并后的序列元素总数为N,则要输出的中值元素位置为(N+1)/2-1(下标从零开始,N无论为奇数还是偶数都满足),输出即可。

 AC代码

#include <iostream>
using namespace std;
int a[200000], b[200000], c[500000]; 
int main() {
	int n, m;
	scanf("%d", &n);
	for (int i = 0; i < n; i++) {
		scanf("%d",&a[i]);
	}
	scanf("%d", &m);
	for (int j = 0; j < m; j++) {
		scanf("%d", &b[j]);
	}
	int k = 0;
	int i, j;
	i = j = 0;
	while (i < n || j < m) {
		if (i < n && j < m) {
			if (a[i] <= b[j]) {
				c[k++] = a[i++];
			} else {
				c[k++] = b[j++];
			}
		}
		else if (i == n) c[k++] = b[j++];
		else c[k++] = a[i++];
	}
	printf("%d", c[(n + m + 1) / 2 - 1]);
	return 0;
}


 更多PAT甲级题目:请访问PAT甲级刷题之路--题目索引+知识点分析(正在进行),感谢支持!

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值