1046. Shortest Distance (20)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 ... DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7

题目大意:

这个任务非常简单:给定一个高速公路上的N个出口,它形成一个简单的循环,你应该求出两个出口之间最短的距离。
输入规格:
每个文件包含一个测试用例。对于每种情况,第一行包含一个正整数N(在[3,10的5次方]),然后是N个整数距离D1 D2 ... DN,Di是第i个和第(i+1)个出口之间的距离,Dn位于第n个出口和第1个出口之间。直线上得所有数字用空格隔开。第二行给出一个正整数M(<=10的4次方),接下来是M行,每行都包含一对出口编号,给定的出口从1到N。保证一圈的距离不超过10的7次方。
输出规范:
对于每个测试用例,将结果打印在M行中,每一行都包含相应的给定出口之间的最短距离。

代码:

#include<stdio.h>
int arr[100001];
int main()
{
    int i,j,n,m,k,t,cnt,x,y;
    scanf("%d",&n);
    cnt=0;
    for(i=1;i<=n;i++)
    {
        scanf("%d",&m);
        cnt+=m;
        arr[i+1]=cnt;
    }
    scanf("%d",&k);
    for(i=1;i<=k;i++)
    {
        scanf("%d %d",&x,&y);
        if(x>y)
        {
            t=x;
            x=y;
            y=t;
        }
        if((cnt-arr[y]+arr[x])>(arr[y]-arr[x]))
        {
           printf("%d\n",arr[y]-arr[x]);
        }
        else
        {
            printf("%d\n",cnt-arr[y]+arr[x]);
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值