PAT 1046. Shortest Distance (20)

1046. Shortest Distance (20)

时间限制
100 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 ... DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7
 
 
AC代码;
//本题在pat上得分不难,但是要得满分,还需要优化算法
//因为数组长度可能非常大,而时间限制是100ms,所以尽量减少遍历次数

#include<stdio.h>
#include<algorithm>
//#include "minmax.h"  //vc6.0 里 min()和max()包含在头文件"minmax.h",pat无需此句
using namespace std;

#define N 100001

int d[N]; //存储相邻两点距离
int i_1d[N]; //存储各点距离起点的距离,以减少遍历次数

int main() {
	//freopen("in.txt","r",stdin);
	int n;
	while(scanf("%d",&n)!=EOF) {
		int total=0; //存储所有边之后,以减少遍历次数
		for(int i=1; i<=n; i++) { //只需遍历一次,随后通过数组i_1d[N]可求出任意两点距离(做差)
			scanf("%d",&d[i]);
			total += d[i];
			if(i==1)
				i_1d[i] = 0;
			else
				i_1d[i] = i_1d[i-1] + d[i-1];
		}
		int m;
		scanf("%d",&m);	
		while(m--) {
			int a, b; 
			int mi, ma;
			int dist;
			scanf("%d %d",&a,&b);
			mi = min(a,b); //将序号小的点的序号赋值给mi
			ma = max(a,b); //将序号大的点的序号赋值给ma
			dist = i_1d[ma] - i_1d[mi]; //做差计算两点距离(路径中不包含起点)
			printf("%d\n",min(dist,total-dist)); //输出“劣弧”
		}
	}

	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值