HDU 1005 循环节查找

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 121076    Accepted Submission(s): 29399


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5
 
        这是一道查找循环节的题 已知 f ( 1 ) =1 && f ( 2 ) =1 所以继续往下查找 当 f ( i ) == 1 && f ( i -1 ) == 1 return i-2;
     详见代码:
#include <iostream>
#include <stdio.h>
using namespace std;
int  data[10000];
int getloop(int a,int b)
{
    data[1]=1,data[2]=1;
    for(int i=3;i<=10000;i++)
    {
        data[i]=(a * data[i-1] + b * data[i-2]) % 7;
        if(data[i]==1&&data[i-1]==1)
        return i-2;
    }
}
int main()
{
    int a,b,n;
    while(cin>>a>>b>>n)
    {
        if(a==0&&b==0&&n==0)
        break;
        int loop=getloop(a,b);
        data[0]=data[loop];//注意循环节最后一个数的处理
        n%=loop;              
        cout<<data[n]<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值