poj-1742 COINS(多重背包问题)

Coins
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 34393 Accepted: 11676

Description

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch. 
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins. 

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4

Source

背包问题汇总:http://www.cnblogs.com/tanky_woo/archive/2010/07/31/1789621.html(别人的)

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
struct money
{
	int x,y;
}str[100005];
bool comp(money a,money b)
{
	if(a.x>b.x)
		return 0;
	return 1;
}
int  n,m,i,j,a[100005],b[100005],dp[100005];		
int main()
{
	 while(scanf("%d%d",&n,&m),n!=0 && m!=0)
	 {
		 memset(dp,0,sizeof(dp));
		 int sum[100005];
		 for(i=1;i<=n;i++)
			 scanf("%d",&a[i]);
		 for(i=1;i<=n;i++)
			 scanf("%d",&b[i]);
		 int ans=0;
		 dp[0]=1;
		for(i=1;i<=n;i++)
		{
			memset(sum,0,sizeof(sum));
			for(j=a[i];j<=m;j++)
			{
				if(dp[j]==0 && dp[j-a[i]]==1 && sum[j-a[i]]<b[i])
				{
					 sum[j]=sum[j-a[i]]+1;
					 dp[j]=1;
					 ans++;
				}
			}
		}
		 printf("%d\n",ans);
	 }
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值