hdu2000 ASCII码排序

题目来源:http://acm.hdu.edu.cn/showproblem.php?pid=2000

ASCII码排序

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 98813    Accepted Submission(s): 41253


Problem Description
输入三个字符后,按各字符的ASCII码从小到大的顺序输出这三个字符。
 

Input
输入数据有多组,每组占一行,有三个字符组成,之间无空格。
 

Output
对于每组输入数据,输出一行,字符中间用一个空格分开。
 

Sample Input
  
  
qwe asd zxc
 

Sample Output
  
  
e q w a d s c x z
 

Author
lcy
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1096  1089  1090  1091  1095 
 
#include <iostream>
#include <cstdio>

using namespace std;

void SwapChar(char &a, char &b, char &c)
{
    char d;
    if(a > b)
        d = a, a = b, b = d;
    if(a > c)
        d = a, a = c, c = d;
    if(b > c)
        d = b, b = c, c = d;
}

int main()
{
    char str[4];
    while(~scanf("%s", str))
    {
        SwapChar(str[0], str[1], str[2]);
        printf("%c %c %c\n", str[0], str[1], str[2]);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值