POJ 3687 Labeling Balls(拓扑排序,逆序)

Labeling Balls
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12256 Accepted: 3510

Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

  1. No two balls share the same label.
  2. The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".

Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, bN) There is a blank line before each test case.

Output

For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.

Sample Input

5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2

Sample Output

1 2 3 4
-1
-1
2 1 3 4
1 3 2 4




和普通拓扑排序一样,只是逆序赋值

ac代码:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#define INF 0x7fffffff
#define MAXN 600
#define max(a,b) a>b?a:b
#define min(a,b) a>b?b:a
using namespace std;
int pri[MAXN][MAXN];
int v[MAXN];
int num[MAXN];
int n,m;
int main()
{
	int i,j,a,b,k,t,bz;
	scanf("%d",&t);
	while(t--)
	{
		bz=0;
		scanf("%d%d",&n,&m);
		memset(pri,0,sizeof(pri));
		memset(v,0,sizeof(v));
		memset(num,0,sizeof(num));
		for(i=0;i<m;i++)
		{
			scanf("%d%d",&a,&b);
			if(pri[b][a]==0)
			{
			    pri[b][a]=1;
			    v[a]++;
			}
		}
		for(i=n;i>=1;i--)//逆序
		{
			k=-1;
			for(j=n;j>=1;j--)
			{
				if(v[j]==0)
				{
					k=j;
					num[j]=i;
					v[j]=-1;
					break;
				}
			}
			if(k!=-1)
			{
				for(j=1;j<=n;j++)
				{
					if(pri[k][j])
					{
						v[j]--;
						pri[k][j]=0;
					}
				}
		    }
		    else
		    {
		    	bz=1;
		        break;
		    }
		}
		if(bz)
		printf("-1\n");
		else
		{
			for(i=1;i<=n-1;i++)
			{
				printf("%d ",num[i]);
			}
			printf("%d\n",num[n]);
	    }
	}
	return 0;
}



 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值