Uva 537 Artificial Intelligence?(Java正则表达式)


  Artificial Intelligence? 

Physics teachers in high school often think that problems given as text are more demanding than pure computations. After all, the pupils have to read and understand the problem first!

So they don't state a problem like ``U=10V, I=5A, P=?" but rather like ``You have an electrical circuit that contains a battery with a voltage of U=10V and a light-bulb. There's an electrical current of I=5A through the bulb. Which power is generated in the bulb?".

However, half of the pupils just don't pay attention to the text anyway. They just extract from the text what is given: U=10V, I=5A. Then they think: ``Which formulae do I know? Ah yes, P=U*I. Therefore P=10V*5A=500W. Finished."

OK, this doesn't always work, so these pupils are usually not the top scorers in physics tests. But at least this simple algorithm is usually good enough to pass the class. (Sad but true.)

Today we will check if a computer can pass a high school physics test. We will concentrate on theP-U-I type problems first. That means, problems in which two of power, voltage and current are given and the third is wanted.


Your job is to write a program that reads such a text problem and solves it according to the simple algorithm given above.

Input 

The first line of the input file will contain the number of test cases.

Each test case will consist of one line containing exactly two data fields and some additional arbitrary words. A data field will be of the formI=xA, U=xV or P=xW, wherex is a real number.

Directly before the unit (A, V or W) one of the prefixesm (milli), k (kilo) and M (Mega) may also occur. To summarize it: Data fields adhere to the following grammar:

DataField ::= Concept '=' RealNumber [Prefix] Unit
Concept   ::= 'P' | 'U' | 'I'
Prefix    ::= 'm' | 'k' | 'M'
Unit      ::= 'W' | 'V' | 'A'

Additional assertions:

  • The equal sign (`=') will never occur in an other context than within a data field.
  • There is no whitespace (tabs,blanks) inside a data field.
  • Either P and U, P and I, or U andI will be given.

Output 

For each test case, print three lines:
  • a line saying ``Problem #k" where k is the number of the test case
  • a line giving the solution (voltage, power or current, dependent on what was given), written without a prefix and with two decimal places as shown in the sample output
  • a blank line

Sample Input 

3
If the voltage is U=200V and the current is I=4.5A, which power is generated?
A light-bulb yields P=100W and the voltage is U=220V. Compute the current, please.
bla bla bla lightning strike I=2A bla bla bla P=2.5MW bla bla voltage?

Sample Output 

Problem #1
P=900.00W

Problem #2
I=0.45A

Problem #3
U=1250000.00V


题目大意:

根据P = U * I公式进行计算。
输入一行字符串,其中给出P,U,I三个变量的任意两个值求出第三个值。


解析:

记得这道题是我上一年做的题目,当时敲完交上去一直WA,后来参考了一下别人的代码才过的。

最近学习了一下正则表达式,然后重新写了一下这题结果一下就AC了。


import java.io.*;
import java.util.*;
import java.util.regex.*;

public class Main {
	static Scanner cin = new Scanner(new BufferedReader(new InputStreamReader(
			System.in)));

	static String numRegular = "(-?\\d+)(\\.\\d+)?";
	static String powerRegular = "P=" + numRegular + "[m|k|M]?W";
	static String currentRegular = "I=" + numRegular + "[m|k|M]?A";
	static String voltageRegular = "U=" + numRegular + "[m|k|M]?V";
	static String formRegular = powerRegular + "|" + currentRegular + "|"
			+ voltageRegular;

	static String a, b;

	static void swap() {
		String tmp = a;
		a = b;
		b = tmp;
	}

	static List<String> getResults(String managers, String regular) {
		List<String> list = new ArrayList<String>();
		Pattern pattern = Pattern.compile(regular);
		Matcher matcher = pattern.matcher(managers);
		while (matcher.find())
			list.add(matcher.group());
		return list;
	}

	static double getNumber(String str) {
		char unit = str.charAt(str.length() - 2);
		double res = 0.0;
		if (unit == 'm' || unit == 'k' || unit == 'M') {
			res = Double.parseDouble(str.substring(2, str.length() - 2));
			if (unit == 'm')
				res /= 1000;
			else if (unit == 'k')
				res *= 1000;
			else if (unit == 'M')
				res *= 1000000;
		} else {
			res = Double.parseDouble(str.substring(2, str.length() - 1));
		}
		return res;
	}

	public static void main(String[] args) {
		int T, cas = 1;
		T = cin.nextInt();
		cin.nextLine();
		while (T-- > 0) {
			String str = cin.nextLine();
			List<String> results = getResults(str, formRegular);

			a = results.get(0);
			b = results.get(1);
			if (a.compareTo(b) > 0)
				swap();
			System.out.printf("Problem #%d\n", cas++);
			double ans1 = getNumber(a), ans2 = getNumber(b);
			if (a.charAt(0) == 'I' && b.charAt(0) == 'U')
				System.out.printf("P=%.2fW\n", ans1 * ans2);
			else if (a.charAt(0) == 'I' && b.charAt(0) == 'P')
				System.out.printf("U=%.2fV\n", ans2 / ans1);
			else
				System.out.printf("I=%.2fA\n", ans1 / ans2);
			System.out.println();
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值