UVA 644 Immediate Decodability


  Immediate Decodability 

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.


Examples: Assume an alphabet that has symbols {A, B, C, D}


The following code is immediately decodable:


A:01 B:10 C:0010 D:0000


but this one is not:


A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)

Input 

Write a program that accepts as input a series of groups of records from a data file. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

Output 

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.


The Sample Input describes the examples above.

Sample Input 

01
10
0010
0000
9
01
10
010
0000
9

Sample Output 

Set 1 is immediately decodable
Set 2 is not immediately decodable


题目大意:

如果在一个二进制的字符串集合中如果有一个字符串,是另一个字符串的前缀就不能立即解码。

否则能立即解码。


解析:

水题直接暴力求解。中间用到了一个strstr()函数

strstr() 函数搜索一个字符串在另一个字符串中的第一次出现。
找到所搜索的字符串,则该函数返回字符串的地址;如果未找到所搜索的字符串,则返回NULL。

(strstr(str[i],str[j]) - str[i]) 就能返回第一个字符串,在另一个字符串中所在的位置。


#include <iostream>
#include <string.h>
#include <stdio.h>
#include <algorithm>
using namespace std;
const int N = 1000;
char code[N][N];
bool judge(int n) {
	for(int i = 0; i < n; i++) {
		for(int j = 0; j < n; j++) {
			if(i == j) { // 相等就不需要判断
				continue;
			}
			if( (strstr(code[i],code[j]) - code[i]) == 0) { //如果前一个字符串在后一个字符串中出现过就不能,立即解码
				return false;
			}
		}
	}
	return true;
}
int main() {
	int num = 0;
	int cas = 1;
	while(scanf("%s",code[num]) != EOF) {
		if(code[num][0] == '9') {
			if(judge(num)) {
				printf("Set %d is immediately decodable\n",cas++);
			}
			else {
				printf("Set %d is not immediately decodable\n",cas++);
			}
			num = 0;
		}
		else {
			num++;
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值