Uva 409 Excuses, Excuses!


 Excuses, Excuses! 

Judge Ito is having a problem with people subpoenaed for jury duty giving rather lame excuses in order to avoid serving. In order to reduce the amount of time required listening to goofy excuses, Judge Ito has asked that you write a program that will search for a list of keywords in a list of excuses identifying lame excuses. Keywords can be matched in an excuse regardless of case.

Input

Input to your program will consist of multiple sets of data.

  • Line 1 of each set will contain exactly two integers. The first number ( tex2html_wrap_inline30 ) defines the number of keywords to be used in the search. The second number ( tex2html_wrap_inline32 ) defines the number of excuses in the set to be searched.
  • Lines 2 through K+1 each contain exactly one keyword.
  • Lines K+2 through K+1+E each contain exactly one excuse.
  • All keywords in the keyword list will contain only contiguous lower case alphabetic characters of lengthL ( tex2html_wrap_inline42 ) and will occupy columns 1 throughL in the input line.
  • All excuses can contain any upper or lower case alphanumeric character, a space, or any of the following punctuation marks [SPMamp".,!?&] not including the square brackets and will not exceed 70 characters in length.
  • Excuses will contain at least 1 non-space character.

Output

For each input set, you are to print the worst excuse(s) from the list.

  • The worst excuse(s) is/are defined as the excuse(s) which contains the largest number of incidences of keywords.
  • If a keyword occurs more than once in an excuse, each occurrance is considered a separate incidence.
  • A keyword ``occurs" in an excuse if and only if it exists in the string in contiguous form and is delimited by the beginning or end of the line or any non-alphabetic character or a space.

For each set of input, you are to print a single line with the number of the set immediately after the string ``Excuse Set #". (See the Sample Output). The following line(s) is/are to contain the worst excuse(s) one per line exactly as read in. If there is more than one worst excuse, you may print them in any order.

After each set of output, you should print a blank line.

Sample Input

5 3
dog
ate
homework
canary
died
My dog ate my homework.
Can you believe my dog died after eating my canary... AND MY HOMEWORK?
This excuse is so good that it contain 0 keywords.
6 5
superhighway
crazy
thermonuclear
bedroom
war
building
I am having a superhighway built in my bedroom.
I am actually crazy.
1234567890.....,,,,,0987654321?????!!!!!!
There was a thermonuclear war!
I ate my dog, my canary, and my homework ... note outdated keywords?

Sample Output

Excuse Set #1
Can you believe my dog died after eating my canary... AND MY HOMEWORK?

Excuse Set #2
I am having a superhighway built in my bedroom.
There was a thermonuclear war!


题目大意:

输入m行的关键词,和n行的字符串。

输出关键词最多的字符串。

注意:

(1) 被这句给坑到了:

If a keyword occurs more than once in an excuse, each occurrance is considered a separate incidence.

如果一个关键词出现两次,每个事件当作一个独立的事件来考虑。

我理解成只要计算关键词在字符串中出现了种类数了。

其实重复的关键词也要计算在内。

英语着急啊。

(2) 就是每个词以空格为分界


1 2
bee
bee ch
beech

输出应该是: bee ch


总结:这题WA了十几次,看了题解才AC。我英语和编码能力有待提升。


#include <iostream>
#include <string>
#include <stdio.h>
#include <string.h>
using namespace std;
const int N = 3000;
string key[N];
string str[N];
string temp;
int m,n;
//temp和所有的关键词比较
bool match(string temp) {
	for(int i = 0;i < m; i++) {
		if(temp == key[i]) {
			return true;
		}
	}
	return false;
}

int main() {
	int cas = 1;
	int count[N];
	while(cin >> m >> n) {
		getchar();
		memset(count,0,sizeof(count));
		for(int i = 0; i < m; i++) {
			getline(cin,key[i]);
		}
		//将所有单词分割进行比较
		int len;
		int max = - 0x3f3f3f;
		for(int i = 0; i < n; i++) {
			getline(cin,str[i]);
			len = str[i].size();
			for(int j = 0; j < len; j++) {
				temp = "";
				while((str[i][j] >= 'a' and str[i][j] <= 'z') or (str[i][j] >= 'A' and str[i][j] <= 'Z')) {
					if(str[i][j] >= 'a' and str[i][j] <= 'z') {
						temp += str[i][j];
					}
					else {
						temp += str[i][j] - 'A' + 'a';
					}
					j++;
				}
				if(match(temp)) {
					count[i]++;
				}
			}
			if(max < count[i]) {
				max = count[i];
			}
		}
		cout<<"Excuse Set #"<<cas++<<endl;
		for(int i = 0; i < n; i++) {
			if(max == count[i]) {
				cout<<str[i]<<endl;
			}
		}
		cout<<endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值