Uva 400 Unix ls

Unix ls
Time Limit:2000MS    Memory Limit:65536KB    64bit IO Format:%lld & %llu

Description

The computer company you work for is introducing a brand new computer line and is developing a new Unix-like operating system to be introduced along with the new computer. Your assignment is to write the formatter for the ls function.

Your program will eventually read input from a pipe (although for now your program will read from the input). Input to your program will consist of a list of (F) filenames that you will sort (ascending based on the ASCII character values) and format into (C) columns based on the length (L) of the longest filename. Filenames will be between 1 and 60 (inclusive) characters in length and will be formatted into left-justified columns. The rightmost column will be the width of the longest filename and all other columns will be the width of the longest filename plus 2. There will be as many columns as will fit in 60 characters. Your program should use as few rows (R) as possible with rows being filled to capacity from left to right.


Input

The input will contain an indefinite number of lists of filenames. Each list will begin with a line containing a single integer (1 <= N <= 100). There will then be N lines each containing one left-justified filename and the entire line's contents (between 1 and 60 characters) are considered to be part of the filename. Allowable characters are alphanumeric (a to z, A to Z, and 0 to 9) and from the following set { ._- } (not including the curly braces). There will be no illegal characters in any of the filenames and no line will be completely empty.

Immediately following the last filename will be the N for the next set or the end of file. You should read and format all sets in the input.


Output

For each set of filenames you should print a line of exactly 60 dashes (-) followed by the formatted columns of filenames. The sorted filenames 1 to R will be listed down column 1; filenames R+1 to 2R listed down column 2; etc.


Sample Input

10
tiny
2short4me
very_long_file_name
shorter
size-1
size2
size3
much_longer_name
12345678.123
mid_size_name
12
Weaser
Alfalfa
Stimey
Buckwheat
Porky
Joe
Darla
Cotton
Butch
Froggy
Mrs_Crabapple
P.D.
19
Mr._French
Jody
Buffy
Sissy
Keith
Danny
Lori
Chris
Shirley
Marsha
Jan
Cindy
Carol
Mike
Greg
Peter
Bobby
Alice
Ruben


Sample Output

------------------------------------------------------------
12345678.123         size-1
2short4me            size2
mid_size_name        size3
much_longer_name     tiny
shorter              very_long_file_name
------------------------------------------------------------
Alfalfa        Cotton         Joe            Porky
Buckwheat      Darla          Mrs_Crabapple  Stimey
Butch          Froggy         P.D.           Weaser
------------------------------------------------------------
Alice       Chris       Jan         Marsha      Ruben
Bobby       Cindy       Jody        Mike        Shirley
Buffy       Danny       Keith       Mr._French  Sissy
Carol       Greg        Lori        Peter

题意:

读入n个字符串,按字典序排序,再按列优先输出,附加条件每行最多输出60个字符,在此条件下要求行最少。

先求出每行最长的字符串,列维是

col = 62 / (cmax + 2);
行维是

row = ceil(1.0 * n / col);
按照 t = j * row + i ; 输出

#include <stdio.h>
#include <iostream>
#include <cmath>  
#include <string>  
#include <algorithm>  
using namespace std;  
const int maxn = 101;  
int n;  

int main() {
	string file[maxn];//保存字符串
	int cmax;		//最大字符串长度
	while (scanf("%d", &n) != EOF) {//输入字符串的个数  
		printf("------------------------------------------------------------\n");//换行  
		cmax = 0; //最大值的初始化
		for (int i = 0; i < n; i++) { //输入字符串,同时获得最大的字符串长度  
			cin >> file[i]; 
			cmax = max(cmax, (int)file[i].size());
		}  
		int col = 62 / (cmax + 2);	//计算出列维  
		int row = ceil(1.0 * n / col);  //计算出行
		sort (file, file + n);  //排序
		for (int i = 0; i < row; i++) {  //两重循环
			for (int j = 0; j < col; j++) {  
				int t = j * row + i;  //临时变量将字符纵向排列
				if (t >= n)	//如果遇到最后一位停止输出
					continue;
				cout << file[t]; //输出字符串 
				int k = cmax - file[t].size();  
				while (k--)  //同时输出空格
					printf(" ");  
				if (j != col - 1)  //如果不是最后一列输出两个空格
					printf("  ");  
			}
			if (i <= row - 1)  //如果是最后一列输出回车
				printf("\n");  
		}  
	}  
	return 0;  
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值