UVa 400 Unix ls 命令

UVA 400
The computer company you work for is introducing a brand new computer line and is developing a
new Unix-like operating system to be introduced along with the new computer. Your assignment is to
write the formatter for the ls function.
Your program will eventually read input from a pipe (although for now your program will read
from the input file). Input to your program will consist of a list of (F) filenames that you will sort
(ascending based on the ASCII character values) and format into (C) columns based on the length (L)
of the longest filename. Filenames will be between 1 and 60 (inclusive) characters in length and will be
formatted into left-justified columns. The rightmost column will be the width of the longest filename
and all other columns will be the width of the longest filename plus 2. There will be as many columns
as will fit in 60 characters. Your program should use as few rows (R) as possible with rows being filled
to capacity from left to right.
Input
The input file will contain an indefinite number of lists of filenames. Each list will begin with a line
containing a single integer (1 ≤ N ≤ 100). There will then be N lines each containing one left-justified
filename and the entire line’s contents (between 1 and 60 characters) are considered to be part of the
filename. Allowable characters are alphanumeric (a to z, A to Z, and 0 to 9) and from the following set
{._-} (not including the curly braces). There will be no illegal characters in any of the filenames and
no line will be completely empty.
Immediately following the last filename will be the N for the next set or the end of file. You should
read and format all sets in the input file.
Output
For each set of filenames you should print a line of exactly 60 dashes (-) followed by the formatted
columns of filenames. The sorted filenames 1 to R will be listed down column 1; filenames R + 1 to 2R
listed down column 2; etc.
Sample Input
10
tiny
2short4me
very_long_file_name
shorter
size-1
size2
size3
much_longer_name
12345678.123
mid_size_name
12
Weaser
Alfalfa
Stimey
Buckwheat
Porky
Joe
Darla
Cotton
Butch
Froggy
Mrs_Crabapple
P.D.
19
Mr._French
Jody
Buffy
Sissy
Keith
Danny
Lori
Chris
Shirley
Marsha
Jan
Cindy
Carol
Mike
Greg
Peter
Bobby
Alice
Ruben
Sample Output

题目很长,题意大致是 先输入一个正整数n,后面是n个文件名,排序后按列优先的方式左对齐输出。假设最长的文件名有M个字符,则最右列有M字符,其他列都是M+2字符。

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
using namespace std;
const int maxcol=60;
const int maxn=105;
string filenames[maxn];
void print(const string &s,int len,char extra)
{
    cout<<s;
    for(int i=0;i<len-s.length();i++)
    {
        cout<<extra;
    }
}
int main()
{
    int n;
    while(cin>>n)
    {
        int m=0;
        for(int i=0;i<n;i++)
        {
            cin>>filenames[i];
            m=max(m,(int)filenames[i].length());
        }
        int cols=(maxcol-m)/(m+2)+1,rows=(n-1)/cols+1;
        print("",60,'-');
        cout<<"\n";
        sort(filenames,filenames+n);
        for(int r=0;r<rows;r++)
        {
            for(int c=0;c<cols;c++)
            {
                int idx=c*rows+r;
                if(idx<n)
                    print(filenames[idx],c==cols-1?m:m+2,' ');
            }
            cout<<endl;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值